Currently being used in bindings error

This is my first time using Webflow, but I’ve been encountering a number of hurdles that are leaving a bad taste in my mouth.

My current hurdle:

I am using a Blog template. I want to change the Category field to be a Multi-Reference field. There doesn’t appear to be a way to change a single reference to a Multi-Reference, so I figured I’d “simply” delete the field and recreate it.

The tool yapped at me saying that I cannot delete the Category field because it’s being used elsewhere. Fine, I search around and remove all references to the field. This process was very tedious and I had to jump through some hoops to figure it out. (Others appear to have had similar issues on the forum).

So now I can delete and recreate the field, but I am unable to save the Collection. When I try to save the collection, I get this error: Collection fields: “Category” currently being used in bindings.

I have no idea what to do with that error. I tried removing the new Category field and naming it something else. No good. I tried removing it all together, but I still get the same error. I tried doing Cmd-S as some have suggested, but that didn’t help.

Does anyone have any suggestions regarding how to tackle this error? Thank you in advance!

1 Like

Welcome to the forums. Please provide required information.

@samliew Thank you. Providing a link would be helpful. :slight_smile: Site is here.
Not sure what to provide with regards to screenshots other than the error, which is attached:


Category is used in Blog collection as a reference field.

Yes, I see that… And that’s the field I’m trying to change/delete, but am unable to.

Click the delete icon here?

That’s exactly what I’ve been trying to do. It will delete it, but when I try to save the Collection, I get the error that I attached earlier. The only way out is to discard my changes.

I see now, the “Categories” Template page contains bindings! Delete everything purple on that page and you’re good.

If you want to keep the design, you could just uncheck the purple bindings in the settings panel, then copy the top-most element to a temporary page first.

Thank you for pointing that out! I removed the binding but, unfortunately, the problem persists. :frowning:
There’s another binding in there too, but it does not appear to have anything to do with “Categories”, and I can’t seem to edit its settings anyway.

The purple bindings in the settings panel are all unchecked. (See image)

Not sure if this is also considered a binding.

You might have to delete the entire purple item (dynamic list as well).

Really dumb question: where are you seeing that? I see what you’re doing in that screenshot, but I can’t get there on my end.

I appreciate your efforts, btw. :slight_smile:

It’s the Blog post dynamic list on the “Category” template page. If it doesn’t work, you might have to delete the whole dynamic list.

It looks like the dynamic list goes as far up as the body tag. That seems odd to me… But that means I’d have to delete the body, which would defeat the purpose the template. :slight_smile:

Those are unchecked, so it won’t be an issue.

I have no idea then. I can’t figure it out.
I found this issue just 10 minutes into using this tool, hence why it’s leaving me with a bad impression.
Thanks though.

This topic was automatically closed after 60 days. New replies are no longer allowed.

Just dropping a note in here that we’ve released a connections manager to help you locate any instance where a collection is connected to your designs. It also gives you the option to disconnect any instance of that collection in one click. :tada: