Streaming live at 10am (PST)

CSV Importing not mapping numbers with decimals to the number field

Hello guys,

Does anyone know about this issue?

“The imported data isn’t compatible with this field” (even though it’s a numeric cell)?

1 Like

Go on the settings of your field, there are options to precisely define the format and how many decimals you’ll input.

Got stuck at this point like you recently, took me a while :smiley:

I have 2 decimals set and still doesn’t work :disappointed: not even with “any format” selected

Needs to be 4.50 in your example with 2 decimals then…

All you data has a correct format?

Number field - only numbers can be mapped to this field. You won’t be able to map numbers to a number field if your values contain letters for example units (100 USD), symbols (eg. $100), or commas (10,000).

Not working either:

This is the field settings:

and this is still what I got:

It’s enough that 1 of the data is not on the good format, or has an extra space, for the field not to bind.
First step to try is to remove all the price data from your csv and only let this 4.50 example. And see from there.

Shouldn’t be working with ‘any format’ setting?

I’m having the exact same issue, no matter what I try. Did you manage to get the issue resolved?

having the same issue here as well, tested with only 1 entry in CSV and it doesnt work for my numbers

Same issue here - I’ve followed all the above steps including ensuring that my CSV is it UTF-8 format. All my other data is in integer format and Webflow happily maps those to number fields. It seems to be specifically decimals that won’t map to Number fields, no matter which format they’re set to (“any format” or otherwise)

@Waldo @PixelGeek

to follow up on the above post - I also tried uploading a CSV with a single row containing one decimal value and the CSV importer still claimed that the decimal was “incompatible” with a number field set to “any format”

@vincent @aaronocampo @mb-dave @spencerj do you know if there was any resolution to this? I have some mild urgency around this as I’m in the process of building a site that’s centered around presenting 100 records of data in percentage format with one decimal place.

Hello @smwvgt

The only option I found for this was to change from a number field to a text one. I know this isn’t ideal in the majority of the cases but for the purpose I needed it worked ok.

Hi @aaronocampo @vincent @mb-dave @spencerj @smwvgt

Thanks for posting about this issue.

I tried testing this on my end as well to confirm and it looks like there isn’t a way to map numbers with decimal places to a number field.

I’ve reported this issue to the team and we will begin investigating to see how we can resolve this.

I don’t have an exact time frame for you, but I’ll be sure to post back here with an update as soon as I have one.

As a temporary workaround you can import those decimal numbers to a text field.

​Thanks in advance for your patience with this.

1 Like

Hey @smwvgt

Webflow reached out and acknowledged it as a bug. Reckon it’ll be fixed soon.

Until then will probably have to do it manually. I got around it creating the basic fields then manually entering numbers.

Still not fixed…

e: was able to workaround this by creating a custom field type in Excel. It looks like this:


Hi Webflow - is this still an issue? I had been importing spreadsheet rows for the last few months and it was fine but now it is failing

Is it working now? Yesterday there were a bit of hickups.

It is actually! Thank you for your quick response!

1 Like

This still seems to be an issue it will not recognise 0.00 as a number. would be great to solve so values can be sorted by value.