Contact form not sending email

hi!
I have my site live at amydale.work and have been testing the contact form 2 things are happening:

  • captcha is not showing up
  • I’m not getting emails from this site

Can someone please take a look and let me know if you see how to fix it?
https://preview.webflow.com/preview/amydale-work?utm_medium=preview_link&utm_source=designer&utm_content=amydale-work&preview=5f83c048be9ab39b751b3293431eb6cc&workflow=preview

Thank you!

Hi Amy check your site-level dashboard settings to see if captcha is enabled and if your captcha key is valid.

Remember once that’s enabled, you need to have a captcha element on every form that uses Webflow’s default form handler.

Am also facing the same situation on my website. Also my website contact form not sending email.

hi @umaralyani
I’m learning that the issue is most likely with my email provider rather than webflow. I’ll share more as I learn.

thank you @memetican
I’m using the form component on all pages and that component holds the captcha, is this what you mean? the only one that might be different is the one on the actual contact page. If I run into issues, what’s the best way to troubleshoot this?

Thank you!

Could be. One way to resolve that is to have the notifications sent from a different origin, or to avoid notifications altogether and have your leads piped into a system like Salesforce, Pipedrive, Nutshell, etc.

If you’re using captcha, you need to have the captcha element on every form that is using Webflow’s default form handler.

That depends on the issue and the setup you’re going for. The first thing to check is whether the form submissions are being captured at all, and you can just check that on the forms page in your site dashboard.

If you are not seeing results there, it’s likely captcha is the issue.