CMS pages showing wrong OG image

Hi,
I have a site with multiple CMS collections. The OG image for collection pages are set to show “banner image” which, as far as I see should grab the image from each particular CMS page and display it:

However, when I share a post on Facebook, for some reason another image shows:

I have no idea where this magnifying glass pic is coming from and how to change it. There is no option to choose an image URL on CMS pages… :frowning:

Please help, it’s making my FB page look horrible.


Here is my public share link: Webflow - The Death Aspect Website
(how to access public share link)

Facebook has a debug tool you can use to isolate the issue. Caching is a common problem. You can also inspect your HTML source to see what each page is providing as an asset.

Thanks a lot Jeff.
I used the FB debug tool and found the image it uses for the og:

It’s the icon for the search functionality. And indeed it is in the html of the page, but it’s not marked as the og image.
Inside the CMS pages I have no access to it, and it doesn’t matter that I’ve set the og image to display something else…

https://preview.webflow.com/preview/death-site-ebb940f99f1217be60eaf0e9e748?utm_medium=preview_link&utm_source=designer&utm_content=death-site-ebb940f99f1217be60eaf0e9e748&preview=1a808e359198412342b69807b28dfa23&workflow=preview

Hi @Yang_9, I took a look and I am seeing something different for the OG image:

From the FB Debugger:

Shared with CloudApp

From an actual share in FB:

Shared with CloudApp

Is the issue still happening on your end?

As the Designer of a site project and making Design changes, it is often helpful to first try the following steps:

– Try to reproduce the behavior while using Webflow in Incognito mode/Private window mode with browser extensions turned off.

– It may be helpful to disable the browser cache so that updated files are always downloaded instead of pulling old content from browser cache.

Only Google Chrome or Apple Safari browser works for the designer, so one thing is to try another browser to see if that helps to isolate the issue root cause.

This kind of behavior can also happen if one one of your custom domains added in the hosting tab is having issues detected.

The issues detected for the custom domains is shown on the hosting tab of project settings.

The next step would be to check and update the DNS records on the domain(s) to point the DNS records at the correct servers.

The root domain (without www, like example.com) should have these two A-records:

Type: A
Name: @
Value: 75.2.70.75

Type: A
Name: @
Value: 99.83.190.102

The WWW subdomain should have a CNAME record and should use the following values:

Type: CNAME
Name: WWW
Value: proxy-ssl.webflow.com

​If you happen to be using Cloudflare, the Status column on your DNS records that point to Webflow must be changed from “Proxied” to “DNS Only”.

After DNS changes are made, got to the hosting tab of project settings, set the
WWW domain as the default domain and then Publish your project.

I hope this helps to give you some things to check.

1 Like

Thanks a lot Dave, for the detailed reply and for looking into it:)
I’ll try everything you say but I just need to clarify that the issue exists for CMS pages only, not for the homepage (which is a regular page).
So for example this page: Ossuary Burial, What's it All About? | The Death Aspect
does not show the intended og image
Article pages which are CMS based have the incorrect og image. Another example: Traditional Inuits and Their Perception of Death | The Death Aspect

Thanks again for taking this seriously :slight_smile:

Hi @Yang_9, thanks for the update. I would check the domain name first in the hosting tab of project settings, it is really important that both domains are connected with no issues detected so that updates to the page are read correctly.

As to the blog post, I am not seeing any OG image attribute at all published and when I looked at the collection page settings, the OG image there had not yet been selected

Can you select the image on the collection page settings, then republish the site?

1 Like

Hi @Yang_9, it looks like you made some changes, I am now seeing something different on the cms pages and the image has updated.

Yes, I changed the setting in this particular page when I was playing with is to see what’s wrong. Generally the OG is set to “Banner Image” on other cms pages.
Anyway it’s working now! I see it just as you do! :slight_smile:

Thanks a lot for taking the time to help :slight_smile: I will also check regarding the DNS settings as you suggest. Most appreciated.

1 Like

Hi @Yang_9., great, thanks for the update, have a nice day :slight_smile:

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.