CMS items not displaying in CMS Collection

Hi there,

I’ve built out some CMS sections and all was working fine. I went in today to make some edits and all the collections say I have 0 items in all of them. However, the panel on the left shows the collections and shows how many items are in them. If I try to make a new item it still shows 0 items in the collection.

I’d prefer not to share the read-only link publicly if possible.

Any ideas?


Here is my public share link: LINK
(how to access public share link)


I understand the frustration you’re experiencing with the CMS collections. Let’s troubleshoot this together. Here are a few steps you can take to resolve the issue:

  1. Refresh Browser: Sometimes, a simple browser refresh can do wonders. Close and reopen your browser or try accessing Webflow in an incognito/private window.
  2. Check Filters: Ensure there are no filters applied in the CMS panel that might be causing the collections to appear empty. Check for any applied filters and clear them.
  3. Clear Cache: Clear your browser cache and try again. Cached data might be causing a display issue.
  4. CMS Editor View: Switch between the “Editor” and “Designer” views. Sometimes, discrepancies can arise between these views.
  5. Webflow Status: Check the Webflow status page ( to ensure there are no ongoing issues that might be affecting the CMS functionality.
  6. Contact Support: If the issue persists, consider reaching out to Webflow support. They can provide more personalized assistance based on your specific account and project details.

Additionally, it’s a good idea to make sure your browser is up to date and that you’re not encountering any network issues.

I hope one of these suggestions helps resolve the issue. If you continue to face challenges, don’t hesitate to provide more details, and we can explore additional solutions.

Thanks for the reply but no luck!

I’ve tried all this, different browsers, different accounts, different computers…

I guess I’ll try contacting support.

1 Like


I appreciate you trying those troubleshooting steps. It’s frustrating when persistent issues arise despite various attempts to resolve them.

Since you’ve exhausted those options and the problem persists across different browsers and devices, reaching out to Webflow support is a solid next step. They have the expertise to delve deeper into your specific case and provide tailored assistance.

When contacting support, providing them with as much detail as possible about your setup and the issue you’re facing will expedite the troubleshooting process. Include information like the affected collections, any recent changes you made, and steps to reproduce the problem.

If you can, also share a read-only link to your project. This will enable them to inspect your project directly and identify any underlying issues.

I hope Webflow support can quickly get to the bottom of this and provide a solution. If there’s anything else I can assist you with in the meantime, feel free to let me know.

1 Like

Hey Spencer, unfortunately this is fairly common over the past 6 months.

It’s worth messaging support, but generally it’s just a “wait until they fix the service outage” game. Should be up in a few hours.

Until then I would recommend you do not try to add items.

The webflow system is a huge assortment of different services and a few of them are relatively fragile. Three I see regularly fail are;

  • the CMS list items endpoint used internally to populate this screen
  • site search. When it’s down, users will simply see no site search results on your site
  • embedly, which handles e.g. video embeds. When it’s down, you cannot add new items successfully
1 Like

I JUST started having this issue too. Showing 10 items in collection, but seeing the same “0 items in your collection” alert when trying to view in Designer.

I’ve been going crazy trying to sort it out, finally found this thread.

It’s a brand new site install too, just loaded up the template from marketplace. Aside from all the suggestions noted here, I even tried deleting the entire site and just trying again - still no luck.

Other sites in my Workspace are fine, no issues with collections and/or their items. Guess I’ll also try contacting support!

1 Like

Same issue here, I have contacted support also

Same issue here as well. Just went into my client’s website to make some final edits before handoff and all my CMS items are not showing up. Just sent a message to support as well, the last thing I need to deal with is a frustrated client not able to receive their website because CMS items are not showing up for me to edit them.

1 Like

I’m having the same issues too! My collections are all missing the information even though the description says they’re in there. I can’t make updates to share with my client tomorrow and this is so frustrating! Sending an email to support as well.

Update: Fixed for me, phew.

I didn’t do anything, just checked this morning an all collection items in Designer were loading up just fine. Guess it was some sort of outage?

Weird it was happening to just one of my sites though, either way hope it’s fixed for everyone else!

1 Like

Glad to hear it’s working for you again! I checked this morning and we’re all good to go here as well. I’d imagine it had something to do with the CMS data returning from AWS and loading into the viewer. When I was troubleshooting with support last night I noticed requests were being sent, returned successful, but the front-end wasn’t handling the info.

For anyone following this, there was a mention in one of these threads of a dialog with support, where the problem was resolved by setting a default Localization setting. If you encounter this, check your site settings.

Best guess is that the designer gets all of the data, but then tries to show you only the data for the currently selected Locality you’re working on. If there is no selected Locality, and no default, it falls over and shows nothing.


Speak of the devil. Webflow is adding localization. Thats the issue. Its creating a mismatch with CMS collections everyone.

I’m experiencing this issue today. Hugely frustrating and causing unnecessary disruption to project work. We have mailed support.

1 Like

Same issue. Localization appears to be set correctly. Correct amount of items shows in the lefthand panel, but I get the default “You have 0 _____ in your collection” for every one.

We’ve reported this issue 10 hours ago to support and have yet to reveive a response. says there are no issues.


I also have the same problem. I’ve just transferred the site to my customer’s account, and it’s impossible to select the standard plan because the CMS collections are invisible. It’s really frustrating because my customer wants his site online quickly and he’s within his rights. And I don’t want him to pay more for a Webflow bug.

Hope this will be solve asap…

I had the same issue after creating a new site from one of the templates. I tried all the suggestions except for contacting support with no luck. Finally I just created a new site from scratch and the CMS was working there. Luckily I hadn’t done much work on the first site so it wasn’t too big a deal but I can see how this would be frustrating if you’ve already done a lot of work building up your site. Maybe there’s a way to duplicate it and see if the CMS begins working again.