Streaming live at 10am (PST)

CMS Images only showing on Webflow URL

I had a bunch of CMS items with images on my site and the published URL’s were working fine. Then I added a bunch more and now the images only show up in the Webflow specific URL and not the actual domain. Any idea what happened?

Here is the Read-only link:


You site is being loaded over Https but your images aren’t. If you want SSL on your site you need to make sure you’ve also enabled it for your images in the site settings.

Go to your hosting settings and scroll down to Advanced Publishing Options


This would be my guess for your situation. Hopefully this helps :smiley:

Wow, I’m dumb haha thank you this worked! What also helped for some reason was bringing the resolution down to 420X420… not sure if that’s the magic number but always a good secondary solution if needed.

Thanks again!

Glad it worked out!

It should work without reducing the resolution, however reducing the resolution is good for load-times anyway so it’s a win win I guess :laughing:

My images are not appearing from my cms as well. I don’t have the option to PUBLISH IMAGES UING SSL CDN under my advanced settings. How can I see this toggle switch?

@operator6004 - Your issue is unrelated to this. Please refer back to your other post.