Can't upload images on CMS

Hi guys!

So I’m trying to upload images into a CMS collection, but every time I try to upload the picture it disappears within 3-5 seconds and it doesn’t save. I use Chrome and I tried logging out and clearing my cache, made sure the size is under max limit, even deleted the image field in collection settings and recreated one and on incognito it’s doing the same thing.

Would really appreciate the help as I’m stumped and not sure if this is a common issue.

Here’s my read-only link: Click Here

Welcome @Danielle :wave:

When you upload an image into the CMS, even before you create or save the CMS item, Webflow immediately uploads your image into their own public CDN to serve that image globally.

That’s why you experience this.

But, it shouldn’t be disappearing. When looking at items in your Plants collection I see the images. For example, this one.

I suspect they are all there now (refresh the browser window). If so, there was just some slowness on their end in getting that thumbnail displaying back to you in the CMS item.

Thanks for the help @ChrisDrit! That makes sense. I tried refreshing my browser window but still the same problem. It’s specifically in the Markets collection when I try to add an image from my file it, it either disappears immediately or stays there but the Save and Replace buttons are locked. Here’s a screen shot of what happens when it’s locked.

I see @Danielle in that case, specifically, I’d reach out to Webflow support with what you just posted. See what they have to say about it.

Got it, appreciate it!