Streaming live at 10am (PST)

Can't upload assets

So I am just learning how to use Webflow and was following the Landing Page Tutorial on Webflow’s Youtube Channel. I downloaded all the assets for the project, unzipped, and was going to put them into the assets panel.

Only some of the assets got uploaded. The company logos (.png files), no problem. But the Texture and Phone asset (Also .png) stopped when the green check mark came and then disappeared. No error, just nothing. I tried again and they got stuck before the green check mark and then disappeared. After that it didn’t even start uploading.

What I’ve tried:
I tried every different way to upload. I have even changed the format in Photoshop to all possible formats. Eventually I gave up and downloaded my own texture. That one didn’t work either. I’m using Chrome. Emptied cache and all that. Still nothing. Sometimes it starts to loa, but most of the attempts now it just doesn’t even show up. I thought maybe it was a limit since I am still on a free account, so I deleted some of the company logos. But now I can’t upload them back either.

Not a great first impression I am sad to say.
Hope this can be fixed.
I searched the Forums and found quite a few posts mentioning the same problem. It was never solved it seems. They all just said that it started working again for no reason. Well I’ve been trying for hours now, and it still doesn’t work.

Hope this can be more looked into because if I had a client deadline this cannot happen.

Best regards!

/Daniel Andersson

Here is my site Read-Only:

Hi, never happend to me. Was it big files?

Hey @Daniel_Andersson how many asset files were you trying to upload? If you upload them in smaller batches or one by one are the results the same? Last question, like @JanneWassberg mentioned, what are the file sizes?

I recommend using to optimize image files.

Any further details you can provide will help figure out the issue or bug. Thanks in advance.

1 Like

Just a 150 KB .PNG file. Should be nothing wrong with the file, it came from the download link of the tutorial. I also tried with one of my own. Still not working.

ok, realy strange. I’m using PNG all the time and much bigger. What was the error message?

We can’t test uploading files into your project. :thinking:Maybe try enabling responsive images and try again.

When I first did it I tried to import all the files I needed in one go. Some worked, others didn’t like I mentioned. I have tried one by one, tried PNG and JPEG, tried dragging it from the file and tried using the upload button. For most people it seemed to just start work again when I checked the forum. But now it is maybe 6 hours later and it is still the same.
I use Windows 10, Chrome (in which I have emptied cache and tried incognito mode in as someone suggested in other thread.

I tried putting the PNG through squoosh and it got all the way to a green check mark again, but then disappeared again like before.

How do I enable responsive images?

The option you are seeing for enabling responsive variants doesn’t show up for me.
And Janne, There was never an error message.
It Stops at either one of these two places in uploading, IF it starts at all. These two are JPEG and PNG that both were run through Squoosh.


This is the original file that I tried with. But no files works.


Ok Update. I tried with the company logos again (who didn’t work before I think), they are all around 10KB in size. I even tried my own logo at 27 KB. It all worked.
The images for this project that doesn’t work are all around 100 KB up.

So I’m thinking, maybe there is a cap on free accounts or something?

Hope you guys will find an answer :slight_smile: Planning on continuing my learning of Webflow tomorrow.

Best regards
/Daniel Andersson

Tagging @Brando or @webflow

1 Like

The read-only link:

I think I have provided all other information already. Now it is the day after and it still doesn’t work.

Please help resolve this quickly. I am planning on using webflow for several businesses, but this has kind of stumped my learning since I can’t practice anything without assets.

Best regards
/Daniel Andersson

Hi @Daniel_Andersson, thanks for your info. One known issue is that images with same name cannot be re-uploaded twice.

As a next step, I would recommend to check that the browser is running the latest updates, and to see if there are any browser extensions loaded that might be conflicting with the Webflow browser code.

A good way to check if browser extensions are conflicting, is to open the browser in Incognito mode (in Chrome) or Private Window mode (in Safari) and reload the site in the designer.

It may be helpful to check to see if your local browser cache is disabled in the browser that is used with the designer.

This will help to force a re-download of latest page changes when those are made, as opposed to pulling from local browser cache.

​See here as an example step by step to disable browser cache in Chrome:

​And for Safari:

​Let me know if that helps, if not, could you send an email to our email along with copies of those images that are not uploading?

Thanks in advance

1 Like

I have tried everything you just wrote, but unfortunately it still doesn’t work.
Saw these errors where I disabled the cache:
Maybe that will help you know what’s wrong?

I’ll send the an email.

Dave. Two days have passed since I sent an Email to the support address. I got confirmation that they recieved it but have not heard anything since then.

I am pretty time pressed to get this working and can’t proceed without being able to upload assets.

Any new idea about what I might try to get it to work while they look into it? Or even a work around.

Best regards
/Daniel Andersson

Hi @Daniel_Andersson

Thanks so much for your patience on this.

I’ve seen and responded to the email you’ve sent us, but wanted to post an update here as well.

The issue’s been reported to our engineers and we’re currently investigating, hoping to get this resolved as quickly as possible for you.

In the mean time, could you please try creating a brand new project, then try to upload the assets there?

​Thanks in advance for your help and patience :bowing_man:

I will respond here also, just incase. I received your email and responded to it. I haven’t heard anything for 4 days now. Is there any workaround or should I use another browser or something?
I really need to create a landing page this week…

I did try with a completely new project. It has the exact same problem.

Could you please check if anything really is being done?

Edit Freaky thing: I downloaded Firefox, and it works. So there has to be something with my Chrome browser right? Anyone have any tips? Plugins shouldn’t be a problem right since I couldn’t do it in Incognito Mode…

Hi @Daniel_Andersson

Thanks for pinging here. Sorry for the delay — I checked our email client and inbox, but wasn’t able to find a reply from you. Not sure what happened there.

At any rate, I’m happy to hear the issue was resolved by using a different browser. Are you on the latest version of Chrome?

I was not at first. However after updating Chrome the problem is still there. The issue isn’t really resolved though. I just found a inconvenient work around. Happy for that, but still hope you can help me find out what’s wrong.

We still have the report open and will dig into it further @Daniel_Andersson. I’ll post back here with more information when I have it :bowing_man:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.