Streaming live at 10am (PST)

Can't see background video and mysterious space under contact form

Hi webflow-oracles!

I spent all night trying to fix these two problems, but at last I resign. Google didn’t help, friends couldn’t help. Nothing worked.

The problems are:

1: In “Section 3” I have a background video field, but even though I have uploaded a video, it doesn’t show up in either preview or on the published site. And I have no idea why.

2: There seems to be a mysterious space under the last section - contact form 2. It dissapears when I delete the contact form, but apart from that seems impossible to get rid of.

3: In all breakpoints smaller than desktop I get an annoying horizontal scroll. I can’t see that I have any elements larger than the VW, and dont see what else could be causing it.

Suggestions will be much appreciated!
Thanks in advance!

Read-only link:

Hey Olin.

  1. There doesn’t seem to be any issue per say, it’s just that the video might be too large in size, so it would take too long to show up. My advice for large videos is to upload them on Youtube/Vimeo or any external platform and embed the URL in Webflow.

  2. Did you fix this one? If not, share a screenshot because it looks fine in my browser.

  3. If you check your “Hero”, you seem to have accidentally set the width to VH instead of VW. It looks fine in Desktop since width is larger than height, but on smaller breakpoints it will overflow.

Let me know if anything else goes wrong.

Thank you Finn!
I will immediately try it out. Brb

The mysterious space:

1: I tried uploading a very small version of the video (7,2mb), but it still doesn’t show up, even if I wait for long in preview.
Embedding a youtube-video wouldn’t be cool, because I would like it to loop indefinitely, but as far as I can see, that is not possible with the embedding - or am I wrong?

2: Screenshot above :point_up_2:

3: Perrrrrrfect! That fixed it! Thank you!

Oh right sorry, I read “contact form” I thought it was the one on the bottom/footer form.

For this one, you added a very large padding to the “paralax” div. So just remove the “246” padding (either make it zero, or something small like 40, if you wish to still have some empty space)

Sorry - you read right. The provided screenshot IS of the contact form on the bottom/footer form. It is the same background video as in the parralax, but at the bottom it fills up the whole VW. Underneath that appears this whole of nothingness, and I can’t select it - it gives me nothing in the navigator doing so. It’s just a whole of nothing.

Okay I found the video issue. I literally have no idea what is in front of it, but it was simply “hiding” behind the background element. Just give it a higher z-index, it will show. I gave it a colored background to make sure it works (because I waited a bit and it seems the connection is slow, so that way I’m sure it’s the connection now). The smaller size video should load perfectly now!

As for looping a youtube video, yeah true, I don’t think there is a way to do that since it embeds the whole player, not just the video.

Holy snap! It worked! I thought I tried that 17 hours ago :joy:
Thank you so much!

2 down - 1 to go. You don’t see the empty space at the bottom of the page in your end?

Yeah the empty spaces seem to be coming from padding and margins given to certain divs. I suggest you just go about reducing those margins and paddings, double check every div (if you hover over the padding/margin numbers, Webflow will actually show you in green/blue the space, so you can tell which ones are too big or unwanted)

Well I like the empty spaces between the different sections. Those are entirely on purpose, and made with padding and margin by myself.

This is very weird, in this specific section I have no empty space showing. IN the screenshot this is the maximum I can scroll down to, and it looks fine.

I cannot think of any issue that might cause that. Does it show even when you publish?

It does. In preview and on published site. What is going on?

I wonder if I’m the only one who get’s that problem. If I am, I might as well just leave it at that, even though it is quite unsettling.

Yeah leave it for now, maybe it’s a glitch in the designer? I sometimes get weird things, they usually go away after I reset my laptop or something like that (could be a RAM issue, browser issue, connection issue?). I really have no other answer, haha. But good luck with it, and feel free to ask anything else. Cheers!

Thank you - You’ve been such a big help!

Ignoring the footer-thing I am pretty much down at one last issue, so I might as well just ask :slight_smile:

On the mobile portrait breakpoint my name and logo on top of the stone arc on the top photo disappear. Do you have any idea why?

Dang - just found one more issue. SO CLOSE to being ready for launch!!

When I turn my iPhone X to horisontal, the image in section 6 (nr 2 from top) jumps to the left. I can’t make it do so on my computer, even if i yank around the sizes in every breakpoint. Any suggestions as to why that happens, and how to center the image for good?

Hey @Olin , sorry couldn’t get back earlier. Could you make your link public again so I take another look?

Hey Charbel
No problem - I’m quite grateful that you even want to help! :blush:
I moved the project to another account, and the new link is:
And the published (actual official real custom) version is at

But - oh no - I discovered that the space at the bottom appears on other computers than just my own. So I guess I have to put it back on the to-do list…

– new to this - but I tried changing the Body Overflow setting from Visible to Hidden and that seemed to clear the “void”?

Could not see it affecting anything else but like I said - just starting - wishing for a helicopter since the learning curve for me so far has been a cliff going straight up :smiley:

Hi Baadtaste
That fixed it for me too. And even better: - it fixed the mysterious space in the bottom!!! Double-win!!! :grin:

Anyone able to figure out where the logo on the top picture goes, when in the smallest mobile breakpoint?
Oh and another thing (things just keep popping up! I guess that’s how this work is…!). The navbar in tablet an smaller doesn’t work?? :man_shrugging: