Streaming live at 10am (PST)

Can't access Editor when I type in my website followed by /?editor

I can’t access Editor when I type in my website followed by /?editor.

I’ve been able to only access editor using Safari but I can no longer do that as well. I tried the following on Chrome since my client said his admin login works well on Chrome:

  • updated my browser
  • cleared cookies multiple times
  • turned off extensions
  • updated my computer (Mac)
    It doesn’t even give me the option to login on the bottom of the site ( Any recommendations?


Did you try to access the Editor through the ,menu on up left corner?


I don’t see anywhere to login despite typing Do you need admin access? I’m not an admin for the site and only have editor privileges.

In the past, I had the login option in the bottom but haven’t seen it this week

Hi @joshjamias,
Try with the following

Yes, I’ve tried that countless times on Chrome, Safari, and Firefox. This has taken at least 3 hours of my time so far in the last 24 hours.

Is there anything you suggest? Any variations of that could work?

1 Like

I have to admit this is weird. I can access both variation of URLs but you can’t.

Last thing I see that you could try is cleaning your dns cache ( not browser cache ).

If you have the time, could you maybe capture a video of the issue with Loom or any other service in order to see the complete behavior of your browser.

Have you also tried in Incognito mode?

Log out from the designer and try the URL you shared in your post. The edit login is appearing at the bottom of the page for me.

It really is weird considering I’ve been able to access it before. I’ve tried incognito mode as well. I also tried it on an iMac and Chromebook in the event that it may just be my computer. Let me try cleaning my dns cache.

Looks like cleaning out dns cache worked! Thanks everyone!

clearing DNS cache hasn’t been working as of late unfortunately

I’ve had this issue for almost 12 months. Whenever I want to “train” my clients on Editor mode, 80% of the time the Editor completely fails — the bottom “Editor navigation” simply does not display. This just happened again today.

It’s embarrassing and a terrible first impression of Webflow for clients. We tell the client for weeks/months: “Webflow is great, it’s doing to be so easy for you to edit! Oh wait… the first time you log in… all you can do is edit the home page.”

This is the case in Chrome, Safari, and Firefox. There is no Editor nav bar at the bottom. No “Collections” no “Forms” — nothing. All I and the editor sees is the “Webflow” logo. ARGH.

I have tried all of these:
[web address]/?edit
[web address]?edit
[web address]/?editor
[web address]?editor

1 Like

and again… the editor login panel and the tabs at the bottom are completely unreliable.

how did you clear your DNS cache @joshjamias ?

On Windows,

open a cmd as admin and type : “ipconfig /flushdns” without the quotes.

@cyberdave - is this something anyone at Webflow can help with? I’ve had 4 of my last 6 client trainings ruined by the fact that new Editors/Collaborators (the client) simply cannot log in to the Webflow editor for their new website. It’s happened enough times on enough people’s machines with various settings (PCs, Macs, Chrome, Firefox, Safari, incognito, all sorts of cookie/cache/extension settings)… over the past 12 months, that I can confidently say the common denominator is Webflow. It’s also been reported dozens of times on different threads on the Webflow forums here for the past 3 years.

bump! Doesn anyone have a solution. Editor shows at my own pc but not at my clients. Giving webflow a bad rep :confused:


Can they login or not or is the login editor overlay (bottom of page/screen not available?

Hi! I´ts the overlay that doesnt show but got an update from clients that it´ll show sometimes in different browsers if you wait long enough. Seem a bit buggy to me though.