Buy Now Button not visible

Hi,

The buy now button is not showing on this page. I’m not sure why. I checked it against the other buttons to see if something was off and it just is not showing up. It is not hidden. The only thing I can think of is that the site is not live yet, just in the webflow domain for building.


Here is my site Read-Only: https://preview.webflow.com/preview/ps-shop-7baca5?utm_medium=preview_link&utm_source=designer&utm_content=ps-shop-7baca5&preview=2009e123dbc187e544c9635110afdbda&pageId=5ee153ac9b12646cc547b983&itemId=5ee153ac9b12641ea247baf4&mode=preview
(how to share your site Read-Only link)

I figured it out.
So Simple.
If the product has a variant, the buy now button is not avail.
FYI, I did not read this in the documentation, it was not there. I figured it out using the link above that has a single item, then changed it to an item that has a variant… That’s when I noticed it is not visible.

@Cherril What did you do to deal with this? I have a product with variants but still need a way for people to buy it! Did you just not use the variants option, or did you find a workaround?

@Cherril I have the same problem (the buy now button is not visible when I publish) but my product has no variant at all then it is not a solution for me. Do you have other ideas to solve it ?

So in looking at this further, i do believe the variants need to be removed. Also, if there is not a payment solution set up, meaning if the stripe is not connected under ecom settings, the button will not show up.

Hope this helps!

Hi @Cherril, @Arthur_Samo, @liam, The “Buy Now” button will only be visible on the live site if a Stripe account is connected and an Ecommerce site plan has been added to the project.

Currently the “Buy Now” button does not work with PayPal, as PayPal uses a different checkout flow and shows a modal prior to sending the user to the PayPal checkout page.

In case you come across this problem what fixed it for me was the checkout option was not turned on. While in designer go to settings → e-commerce → checkout → toggle the switch on.