Blog CMS content with Links inside does not show up as link in the post

Have a blog CMS content and in the rich text of the blog I have content with links to external site. In the CMS editor those show up as “blue” links - however when I link to that CMS in the template page in the rich text block - they show up as flat text without any of theblue hyper links.
Am I doing this right or is there a better way.

You haven’t shared any links to your project or even screenshots- so it’s difficult to help you.

I’ll guess that by “CMS editor” you must be referring to either the designer CMS windows, or the CMS editor view that collaborators see ( and not the WYSIWYG editor view ).

In the pop-up CMS editors, you’re seeing raw content, with zero styling.

In the designer canvas, your standard WYSIWYG editor views, and in the published site, your site styling shows.

So from your description, you have your links styled as plain text. You’ll want to read the Webflow U courses on styling, and how to style the rich text element specifically.

Hard to fully understand but it sounds like you have some class applied to your RTE and it’s changing the style of those links.

Checkout the Advanced Styling section of this and see if it applies:

Also, maybe you’re getting effected by something like this:

sorry for the confusion.
This is a screenshot of what it looks like in the webflow editor in the rich text field

however when I publish it - it shows up just as bolded text - I cannot find a way to change the color or underline it.
this is a link to the blog:

It’s difficult to know what you’re doing without a project share link.

But inspecting your site:

You’re most likely inheriting the “All Links” styling.

If you stop inheriting it you’ll see that it returns to the default blue link:

Check those settings in the Designer.

Hello everyone! Hoping to get some help-I have VERY little experience with web design/coding and it is all overwhelming!

I am having a similar problem …none of my Amazon affiliate links are showing up when I copy + paste my blog post from Google Docs to the editor in Webflow. I never had this issue before. I have tried clearing cache, uninstalling ad blocker but it is still not showing up.

https://preview.webflow.com/preview/merry-madden?utm_medium=preview_link&utm_source=designer&utm_content=merry-madden&preview=80e4ff68d6be520ce880d8a44052daba&workflow=preview

Hi Merry, it looks like you’re pasting your content as unformatted text.

On Windows, could be you’re hitting CTRL+SHIFT+V when you paste. Otherwise, check for clipboard utils you might have running.

@memetican thank you for your quick response!! My apologies, I should have mentioned I am using a Mac. I use command + c then command +v, normally never having an issue but it is still not carrying over the formatting. :slightly_frowning_face:

Sweet. I can only observe what I’ve seeing, which is no links… so the problem is somewhere between your source content, your clipboard, your browser, and Webflow. The best I can recommend is;

  • clear your cache
  • disable any browser extensions
  • try copy paste from other documents
  • copy paste your content to another target
  • if that preserves the HTML links, try copy-paste from there to Webflow
  • try it from another computer

If none of that works then I’d contact support.

Ah one possibility that might be related is that sometimes I see Webflow identify clipboard content as markdown based on certain characters, like # at the start of a line. If it thinks it’s markdown, it may run it through an entirely different pre-processor.

1 Like