Streaming live at 10am (PST)

Allowing users to upload files through your Webflow forms with Uploadcare

@YoavGivati , Webflow engineer, found this simple tutorial from Uploadcare.

Now you can upload files from your Webflow forms :slightly_smiling: Enjoy!


Hi,I can’t seem to get my files uploaded through uploadcare with the widget on the webflow. How do I make it work?

1 Like

Hi, this is nice. But i can’t receive mail anymore through the webflow mail form to my forwarding email address which i entered at the settings page of my project. I followed every step at the tutorial exactly as written.

What could i’ve done wrong? Do you have any advice @PixelGeek


1 Like

Pls don’t regard my previous message. I solved the issue.

Hi, same thing happened to me, followed every step but did not work. How you solved?

Hi @aykut and @Mario_R_Luna_Meza Could you please update your comments with some more information so we can help you faster? Things like your read-only link & screenshots really helps us to help you faster :slight_smile:

How to share a read-only link:

Just to confirm, do you have a hosting subscription on the sites you’re using to get the form submissions?

Hi @Mario_R_Luna_Meza

In my case, i did this mistake to duplicate an existing Textfield, which was set on “required” mode. Thus mails couldn’t delivered because this filed wants to be filled out with text.

Therefore you only have to create a textfield from scratch, name it hide, set the ID Upload-Picture, add the Attribute (which is delivered at the tutorial page) and enter the generated code by uploadcare to the head code section in your settings panel.

Hope that hepls :wink:

When I put the code into the form, test it, it all works just fine. But the email that is sent from the form has “Field 18”, “Field 19” etc. Is there a way to change that? Can it be changed? If so, how/where?

Screen Shot 2020-11-17 at 4.29.44 PM

And the form is located on which page?

Order online page.

Not seeing any file fields for upload. What am I missing?

Scroll up to see the screen shot I attached earlier. It’s a screen shot of the email.

Here is the screen shot again to make things easier.

The bottom has Field 18, 19, etc. How can I change that to File 1, 2 etc.

Screen Shot 2020-11-19 at 2.06.23 PM

I was talking about the form field used to upload files. I had to go look at the source to see that it was hidden (an uploadcare file upload input ) on the page. I suggest you reach out to uploadcare support.

1 Like

I’m sorry. I guess I wasn’t understanding what you were asking for. My apologies. I will contact them and see if they know what’s going on. Thank you.

1 Like

No problem. It looks to me the script is writing the value back to the form field. It’s a blackbox so best to go to the source.

Ah ok. No clue what that means as I am learning but good to know. :slight_smile: