Adobe Fonts won't load into site

Hi everyone, trying to connect Adobe Fonts to use in my project. I activated the desired fonts and copied the API token into Webflow. I tried pasting and saving changes in both the site and workspace settings. But the moment I click save a red bar flashes at the top of the screen and takes me to the Webflow homepage. It flashes too fast to grab a screenshot. If I go back to font settings I find it set to none. Does anyone have an idea why this is happening? Thank you!

I’m not sure on your specific case, but I opened a project today and the Google font does not display in the designer even though it has been working previously. So I uploaded the font files manually and this fixed it. Can you download/upload directly rather than relying on Adobe fonts API?

Hey, thanks for replying. Unfortunately, I don’t have the font files. I tried finding where Adobe stores them locally but I think they restricted access now. I tried uploading the same fonts from free sites but the fonts end up unreadable or choppy and they don’t actually look like the Adobe equivelants. Not sure if this is just how they look on Webflow but they don’t look like that on Illustrator.