301 Redirect not working, error message result

This page is being disabled Cin7 Integration and Installation Partners - The Back Office Company and I need to 301 redirect it to another page in the site, but when I create the redirect I get an error message telling me that “/cin7 is already a page for this project”, which I don’t understand; I’m trying to direct away from not ‘/cin7’, not to it.

The screenshot shows that the page doesn’t exist as a redirect either.

Appreciate any explanations as to how to get around this or why it’s happening.


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Rename /cin7 to e.g. /cin7-old.
Then you’ll be able to create the redirect using /cin7.

Thanks Michael, but it hasn’t worked. The same thing is happening as seen in the attached screenshot after trying what you’ve suggested.

No, not redirect, rename.
You need to rename your PAGE that has the path /cin7 to something else.
Otherwise you can’t create a redirect entry for it since that path is already taken.

But wait, you’ve created a redirect for /cin7/cin7-old with means you’ve already solved the page path conflict problem.

I’m not sure what that redirect is meant to do.
Delete that one at the bottom, and you’ll be able to create the one you’re trying to.

Correct, I have renamed it to cin7-old, Webflow creates it’s own redirect when this happens (at least that is my understanding of what I see when a page gets renamed).

The client wants the disabled page’s URL /cin7 (now /cin7-old) to redirect to another page on the website so as not to have a page not found error and to keep the ranking.

Every time I create a redirect for /cin7 (or now /cin7-old) I get the error message.


Unfortunately, no, I wish it did particularly for CMS item slug changes. But that’s not a feature yet.

I’m not sure why you’re redirecting /cin7 to /cin7-old, I thought you are wanting to disable ( but not delete ) that old page, and redirect /cin7 somewhere new?

So remove that one you’re highlighted in green, and create one pointing /cin7 wherever you want it to go now.

Hi. I’ve just had Webflow Support helping me on this too. They’ve pointed out something I didn’t know, when you rename a page url an option to automatically apply a redirect to the new url appears, which is why I was having the problem. The attached screenshot shows where it appears.

Yes I did want to disable the page, the /cin7 to /cin7-old is the redirect Webflow automatically created.

Cheers for your help!

1 Like

I have actually never seen that before, I wonder if it’s new.
Thanks for sharing!