Weglot media link not translating

Hi everyone,

I have a website that I translated with Weglot, the problem I have is that I wan’t some different images on the translated version. I followed Weglot’s tutorial, but it doesn’t work. I read that this problem is common and used an embed with the image source code. But that doesn’t work either.

Maybe someone knows an easy fix?

The image is on the ‘voor werkgevers’ page.

Read-only

Have you tried using CSS to show/hide images based on the language class Weglot adds to the body tag? For example, if you have an English version and a French version, you could have two sets of images on your page, one for each language. Then use CSS to display the relevant images for each language while hiding the others.

Here’s an example:

body.language-en .image-fr {
  display: none;
}
body.language-fr .image-en {
  display: none;
}


In this code, .image-en is the class for images shown in the English version, and .image-fr is for the French version. Adjust the language codes and class names as per your website’s setup.

Cheers!

Thanks for your message! I don’t get it to work tho. Maybe I did something wrong with the code?

It sounds like an easy fix, would be awesome if it works. It is on the ‘Voor werkgevers’ page and mobile landscape viewport.

read-only

I got it working based on the information from this blogpost Hide an element on your Webflow site according to the language!

The downside is that it only works when I click on the translation button. So when you visit the page both translations are visible :confused:

I got it working! Just follow these instructions: Hide an element on your Webflow site according to the language!

And this is important, don’t forget to set your ‘lang’ code in the webflow site settings: how to enter your lang code