Vimeo video link attributes disappearing in CMS

Nope, I wrote the CSS in the same custom code component as the video, like so:

.embed-container {
	position: relative;
	padding-bottom: 56.25%;
	height: 0; overflow: hidden;
	max-width: 100%; height: auto;
.embed-container iframe,
.embed-container object,
.embed-container embed {
	position: absolute;
	top: 0;
	left: 0;
	width: 100%;
	height: 100%;
<div class='embed-container'>
	<iframe src="
		webkitallowfullscreen mozallowfullscreen allowfullscreen>

Ah. OK. That might be the problem. Mine’s in the custom code head field. I’ll try it in a sec and let you know. Thanks for all your help. It’s much appreciated.

So… I copied your code from above and pasted it into my embed widget and then swapped the xxxxxx for my vimeo video unique ID (from the vimeo embed code on their site) and closed off the quote marks on the video URL (webflow flagged the code in red as problematic until I did that) then I removed the CSS from the custom code head tag and published the site. The video does not display in Firefox or edge.

So I created a new page with just the video embed widget… and the video displays in firefox and edge.

So… it’s something else that I have in my page that’s causing the issue. Now I know it works I’ll now debug my pages to see what’s causing the problem.

Thanks for all your help.

1 Like

I think I’ve discovered that putting your embed DIV inside a flexbox element breaks it’s visibility.

Hi @Brando :slight_smile:

I hope this message finds you well ! I just wanted to know if the team had time to investigate the little stripped out part of the vimeo autoplay url setting ? The workaround we found still work, but I wish I could specify which video should autoplay and which not as I have many different video on one page :slight_smile:

Hope you don’t mind me bumping this message up !

Hi @anthonysalamin

Thanks for following up with this. I spoke with the team and we don’t yet have a solution to the issue.

I wish I could provide an exact time frame here, but I’ll be sure to update you as soon as I have more information.

Thanks for your patience so far. I know the workaround is not an ideal solution, but I’m happy it’s still working for you.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.