Upload image button won't work in CMS

Hi, I’m trying to upload an image to a blog post in my CMS. When I click on the transparent “+” button, the menu to upload images, videos, etc pops up briefly and disappears. It’s not clickable. Related, when I try and upload an image to the asset manager I get a “filename error” which doesn’t make sense (the file name is 5 characters.

I’ve tried:
Clearing cache
Restarting Chrome
Restarting computer
Using incognito mode
Using Safari

None of these allow me to upload / place an image in my post.

Fwiw, using incognito mode does get rid of the filename error.

I’ve seen this problem raised before but the solution was clear cache or go into private mode and I’ve done that.

Let me know! Thanks!

Here is my public share link: LINK
(how to access public share link)

Hey Stu, looks like you’ve done the right things, one other possibility is to attempt from another network / computer. In rare cases I see issues with routers / proxies or antivirus setups that use VPNs.

Another thing is to make certain the file type is supported and that the size is under 4MB, just in case the error message being displayed is incorrect.

Beyond that, it sounds like a system issue and you’d need to contact support.

Ah, thanks!

I used a VPN (Netherlands) and it worked. So it could be my Spectrum router (I’m in LA / that’s our broadband provider).

1 Like