Streaming live at 10am (PST)

Unable to rename or duplicate class

Hi, I’m having an issue with Webflow not letting me rename or duplicate a specific class in my project.

So if I try to rename the class Webflow will tell me that the name/class “already exists”:

And if I try to duplicate, nothing happens when I click “Duplicate”:

Here is my site Read-Only: Webflow - Gramo

I can usually pin issues like this down to browser extensions interfering with the designer. If you are running any this could be your issue too. Normally for Webflow work I run my browser in incognito mode to avoid issues. If this does not resolve it for you then share your read-only and browser / browser version, OS and OS version.

I’m facing the same issue. Mistakenly renamed “Section” to “careers” and not there’s huge confusion site-wide. Did you find the fix?

Hi Bastian,

As Jeff has mentioned, the first thing to try here would be disabling all browser extensions and using an incognito/private window, this will rule out a cache or plugin issue. Also ensure your browser is up to date, as well as your PC/device.

If you continue to experience issues, try using a different browser, or restoring your current browser to its default state.

Failing all of the above, please contact us using the link below and we can look into this further for you.


1 Like

Hi Sharvan,

If you haven’t already closed the Designer, you can simply “undo” the changes.

If you have closed the Designer, you can restore a backup of your site. You can read how to do that using the link below.


Hey Logan,

Thanks for replying. I went ahead to make a bunch of changes to the site, so cannot undo or restore backup now. That’ll undo all my work.

I also tried the editor in incognito and without browser extensions. Still facing the same issue.

I’ve posted about the issue on a different thread here, Class name "Already Exisits" bug. Please do look into it. Thank you.

Quick update: Figured it out.

Could go into the Style Manager section and change the name, but changing the name under the editor tab still does not work (bug).

I’ll close the other thread too. Thank you.