Streaming live at 10am (PST)

Typeform Broke Site Scrolling - HELP?


I tried to implement Typeform to my website’s pop-up window, and it worked! But it broke the scrolling function on the exported website and I’m going nuts, would someone be ultra-awesome and take a look please?

In order to see the Typeform form, you need to click on the contact button that says “Solicite un presupuesto”

Public Preview Link:

Published Website:

What is the exported website URL ?

What is broken?

Does the typeform exceed the page height and get lost below?

This is the exported website:

The scrolling of the entire website is broken since I added the Typeform to the Popup.

It has 100vh & 100vw, it can’t exceed the site’s height.

i think you just need to add scroll to the html embed. That way if the embed exceeds the height it will scroll down on it.

What do you mean I should “add scroll”?

look at image. For the html embed there set overflow to automatic scroll. If the element exceeds the view width height it will allow the element to scroll. And if it doesn’t exceed height it won’t use the scroll

Did as you said but keep getting the same result :cry:

I’m not seeing what the issue is. Are you trying to prevent scrolling while the type form is open? That will require some coding i think. I go to the typeform and can input info no problem. Maybe I’m not going through it enough. Type form seems to have an internal scroll anyway. Do you not want type form to block the whole site?

Typeform works just fine! It’s the homepage that won’t scroll since I included the typeform.

The problem is not inside the contact popup, it’s outside. I can’t scroll to the bottom of the page, the scroll has somehow been disabled and I can’t get it to work. :frowning: :frowning: :frowning:

I’m trying to get the website to scroll when the popup window isn’t open.

On my screen I can enter the information in Typeform no problem and when i hit the close button it goes back to your site. What browser are you testing in?

I’m using Safari! But I get the exact same problem on Chrome

And yes, It does go back to the website when you close the popup, but the website itself (not the popup) won’t scroll… Try scrolling to the footer of the website and you’ll see.

Ok I see, now. Try using the css to set initial appearance none. Instead of interaction for the popup. See if that does something.

The CSS is already set to display:none for the popup, besides the interaction :confused:

But you have the interaction set as display none to popup as well.

Ok I see, already disabled that interaction and still get no results. Such a weird problem! It all worked just fine until I included the typeform…

That is weird I haven’t used typeform on a site yet so I don’t know the answer. I just checked if the Popup was blocking the scroll. You wouldn’t be able to interact with menu or other page elements. I have done that a few times. got me stumped. Lo Siento

From what I can see currently you have your html element set to overflow hidden. You have added custom css in the page settings to do that.

It prevents the page from being scrolled. Remove that CSS and let me know if there is still an issue.

1 Like

You, Sir, are my king of the day and queen of the night (?)

Just kidding, but hey, it worked! Guess I just rushed and didn’t pay attention to WTF I was doing haha.

Thanks, Alex! Hope you have a great day :slight_smile:

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.