Still No Fix for CMS Issues

Okay, so this is part query for other users and part rant. Weeks ago I suddenly noticed strange things beginning to happen with my CMS content - odd returns on text blocks, inability to select and edit text properly and general strange behaviour resulting in basically being unable to add work.

I submitted a support call and have since received very sporadic assistance, when I am usually more than happy with response times and content. The assistance consisted of varying degrees of admittance of an issue cause by a new CMS editor being rolled out affecting unicode characters when text had been copied and pasted from other editors.

Fair enough, issues happen, but I am now seeing other problems such as links breaking whenever I click on them or select them within the CMS editor.

The biggest issue I noticed was that whole parts of content had just disappeared, and this was throughout my whole site.

I have since had to go through my entire site and re-enter whole parts of missing text and reapply links throughout - although this is virtually pointless as they break the next time I happen to place a cursor next to them anyway. Everything now has to be checked, checked and checked again to ensure it is working - and this is old content, which worked up until the new updates.

My concern is that there has been nothing overtly published to notify customers about this issue. I am also concerned for designers who manage multiple sites with many more pages than mine. This could be a disaster for them.

Has anybody else had these issues beyond the general chat about strange CMS in the following?

Webflow is expensive but incredibly adaptable. I have been converted entirely, and always fairly relaxed about certain oddities, unexpected behaviour but this is different - a major bug with virtually no customer notification, particularly given the seriousness of the issue in terms of random loss of content, let alone the other issues.

Hi @spok

First off, thanks so much for sharing this candid feedback.

You definitely bring up a lot of good points. The main cause for these rich text issues is a major update we made recently. You can read more on this here, but the gist is we have completely refactored how text is edited across Webflow (CMS, Designer, Editor).

That said, a lot of the issues originally reported have been resolved (i.e this and this).

However, this issue that you mentioned is definitely concerning:

The biggest issue I noticed was that whole parts of content had just disappeared, and this was throughout my whole site.

I’m happy to investgiate this further for you — can you reach out to our Support Team directly and provide more details about this?

Regarding not receiving specific notifications of the issues; we definitely could have done better with communicating the issues. Unfortunately, the impact from these content editor issues was a bit sporadic and only affected some users.

We definitely want to make sure there are no more content Editor bugs lurking around, though. Our team is standing by for your bug report with more details.

Thanks again for voicing your concerns here — we definitely appreciate the feedback :slight_smile:


Many thanks for the reply - I have only just noted it.

I have since corrected all issues so have nothing I can submit but my support requests should be recorded for reference?

I will continue to monitor as I make changes and report any further issues.

1 Like

Happy to hear the issues have been resolved.

We’ll definitely keep this feedback post available for our team and don’t hesitate to contact us directly or post on the bugs category for specific issues.


Ah, sorry no. The copy/paste from one CMS to another still exists, as does the links’ link disappearance when selecting but I know there are supposed to be fixes coming out so have manually fixed all the issues in this thread but will keep an eye out and let support know if it continues.

1 Like

I wanted to raise a support query but also thought it worthwhile posting here. I am still having huge issues with editing CMS content, even after re-writing. Images and links do not copy/paste and general basic selection and overall use is incredibly frustrating.

I had one piece of news to add to our website, which required shifting existing CMS content down a box - basically copy and paste each box which contains text, image and link.

Could not select the text easily, or images. Still could not copy CMS entire to paste - had to do it by text and then image. When pasting into a new CMS box, there were random formatting issues. For example, header space above the top line with no way of removing - I must highlight that this text has been re-formatted in Webflow.

If I then saved, closed and then re-opened the page, I could occasionally paste a piece of text, and rarely the image to follow before having to repeat the whole procure.

In each block, I also had to re-link every copied link on the page.

This is actually becoming unacceptable, the whole point of CMS is to enable better content editing. But I can barely edit - this in addition to the previous issue of disappearing content throughout my website, and the fact that it is months old as a known problem…

I felt it necessary to post this on a public forum, as support had been sporadic at best, with more of an attitude towards ‘well, yes, it’s a known problem’ and nothing really any further. I mean, I was losing content, and can now barely edit that content.

It is frustrating because Webflow is great but expensive. And having pushed so hard for using your platform with our directors, it does not reflect well.


1 Like

So another support and forum query ignored. Surely copying and pasting from one CMS box to another including links should not be an unreasonable expectation?

This issue has existed for months now and I still have no conclusive response as to a planned fix.

1 Like

I can’t believe this has not been looked into. We are experiencing this same issue in 2022. Typing behaviour sporadically deletes or inserts text between existing. Pressing Backspace or Delete completely scrambles the section of paragraph that is being edited. Wtf is going on in here?

@Brando Has Webflow refactored their typing once more, recently? We had a completely finished off website, and now we are unable to fix the typing errors that have been created, by what sounds to be a WF glitch. We have tested on both Chrome and Firefox. See my original post with links here: Webflow is scrambling my text upon publish

I would greatly appreciate help to get this resolved ASAP. We are paying a lot of money to have our website make us look like fools without spellcheck or control over paragraphs. Seriously.

I am really surprised to see this is still a problem - I ended up having to re-write most of my content in the end. Now I basically either write my text in notepad or - ff written in Word for example - copy and paste into notepad. From there, paste as plain text into the CMS editor. It was the only way I found that could guarantee none of this bizarre behaviour. Sadly, because the issues had effectively disrupted most of my content, there was no retrospective fix but hopefully this will help you with any new content you add to CMS…

1 Like