Streaming live at 10am (PST)

Slider arrows sometimes don't work (solved)

Hello guys, I have a problem with slider arrows, I’ve thought that mb after a publishing site it’ll disapear, but it don’t.
So, usually right side arrow working ok, I can get to 4th slide, after that I tried to get back to 1st slide, left side arrow wokk usually 1 time, after that it doesn’t work, also right side arrow don’t work now too.
Any thoughts?
Thanks for attention

Is there any possibility to add some visual effect to pressed dot? Now they just look the same

Seems like find the solution of problem, now I need to turn on “infinite scroll”, but it disabled now, any thoughts why?

Not sure why that’s happening. Can you post your Public link so i can see?

Also, you can invert the nav circles so they will stand out more. You can also customize the color of those as described here:

1 Like
Here it is, man.

@ForFood We found the issue with your Slider.

If you select the Slider Mask element and remove the Display style, that should fix the z-index issues. See the attached screenshot for details:


Oh, it works good now, big thanks man. Can u explain me, what was the problem? Why Display style make trouble?

This was because of the quirky way that z-index stacking order works in CSS. Since the Position was set to Auto (which translates to “static” in CSS), the Mask was being removed from the z-index stacking context… which in turn allowed the Mask’s inner elements to stack above everything else.

Basically, the images in the slides were overlaying the arrows causing the buttons to be ignored.

1 Like