SEO Video Indexing Issue "No Thumbnail URL provided"

Hey everyone! With my most recent website project, I’ve put considerable effort into making my site as SEO optimized as possible. I’ve generated a sitemap and sent it to the Google Search Console, and I’ve since received an email notifying me of a ‘video indexing issue’ on a couple of my pages.

According to the search console, the pages in question are my photos page and my FAQ page. The strange thing, however, is that neither of those pages contains a video element on them, yet google is telling me the page is ‘containing a video where the page could be indexed, but no video could be indexed’. The large error text states, “No thumbnail URL provided”.

Does anyone know what might be going on? I’m pretty new to these SEO integrations so want to make sure everything is set up properly! Thanks you everyone!



Pages in question (that to my knowledge are not video pages):

https://www.loom.com/share/394dd495250f409f9d9d7294473be196

Here is my site Read-Only: [LINK][1]

I have the same issue as well. I believe it’s a new Google metric. Does anyone have a fix for this yet?

Thankful for anyone who can provide any insight to this ongoing issue. I don’t know a ton about the Google Search Console, but I have a feeling that a failed validation might negatively impact my SEO rankings.


The packages page does not contain a video element. Why is Google Search console indexing this page as a video page?

1 Like

Google offers documentation on most of its products and features. Here is what they provide regard this topic.

Thank you Jeff, but it seems Google’s solution to not having a video thumbnail url is as follows:

“No thumbnail image was specified for this video, and Google was unable to generate one for you. Provide a link to a thumbnail for your video using structured data, a sitemap, or an mRSS file.”

Is there a way to do this within Webflow? Can we provide a link to a thumbnail in any of the three ways they request us to do so?

@jholla12 - You can use custom code for video and meet their requirements. The built in video element might not accommodate that new feature yet. Embed.ly might (used in rich text fields).

Separate but related, I arrived at this thread when researching about the video/thumb warning.

I was getting this because of background videos. I don’t believe there’s a thumbnail option within Webflow. I checked the “Exclude background video from site indexing” under settings.

Edit: After implementing “Exclude background video from site indexing”, I still receive the error in GSC.

I too am getting the same Search Console error flagged by Google for this page CMP Construction

The page is using Webflow’s Youtube/Vimeo video element which doesn’t require or have any thumbnail element option as part of its attributes. (Looking at the Vimeo code in this page’s example, the iframe code does call a thumbnail image, as follows, data-thumb=“https://i.vimeocdn.com/video/1198451819-36d3b324f049b172dd127361c7b46f61bc73374c8d6f94ec7863242914e80273-d?mw=1300&mh=731 Shouldn’t Google be acknowledging that?)

Surely if a fix is to use custom code to deliver the video and thumbnail this would make the video element redundant?

Seems to be something that Webflow needs to address. Webflow, can you please look into this as the video element, as it currently is, is not really of any use if Google Search Console is going to rank it negatively.

You can follow these steps to try to resolve:

  1. Inspect your pages’ source code: Make sure there are no video-related tags, like
  2. Check your sitemap: Webflow automatically generates a sitemap for your site. Visit yourwebsite.com/sitemap.xml (replace “yourwebsite.com” with your actual domain) to view your sitemap. Ensure that your sitemap doesn’t list any video content for those pages. If it does, you can manually exclude pages from the sitemap in Webflow by following these steps:
  • In your Webflow Dashboard, go to your project’s settings.
  • Click on the SEO tab.
  • Scroll down to the “Sitemap” section and click on “Edit sitemap settings.”
  • Exclude the pages with the video indexing issue and click “Save.”
  1. Schema.org markup: If you’re using Schema.org markup, double-check that you don’t have any video-related schema (e.g., VideoObject) on those pages in the Webflow Designer. Remove or modify any incorrect schema to prevent false identification of video content.

  2. Custom code, widgets, or integrations: Check any custom code, widgets, or third-party integrations you’ve added to your Webflow project that might be adding

You can follow these steps to try to resolve:

  1. Inspect your pages’ source code: Make sure there are no video-related tags, like
  2. Check your sitemap: Webflow automatically generates a sitemap for your site. Visit yourwebsite.com/sitemap.xml (replace “yourwebsite.com” with your actual domain) to view your sitemap. Ensure that your sitemap doesn’t list any video content for those pages. If it does, you can manually exclude pages from the sitemap in Webflow by following these steps:
  • In your Webflow Dashboard, go to your project’s settings.
  • Click on the SEO tab.
  • Scroll down to the “Sitemap” section and click on “Edit sitemap settings.”
  • Exclude the pages with the video indexing issue and click “Save.”
  1. Schema.org markup: If you’re using Schema.org markup, double-check that you don’t have any video-related schema (e.g., VideoObject) on those pages in the Webflow Designer. Remove or modify any incorrect schema to prevent false identification of video content.
  2. Custom code, widgets, or integrations: Check any custom code, widgets, or third-party integrations you’ve added to your Webflow project that might be adding

Hi Douglas, can you post a screenshot of where you’re seeing the Edit sitemap settings in the SEO tab please. I can’t see it anywhere.

  • Scroll down to the “Sitemap” section and click on “Edit sitemap settings.”
1 Like

Hi @Port_of_Folio, I am facing the same exact issues currently! Can i ask if you have found a solution for this? Thank you!

Setting the video to “Exclude background video from site indexing” worked. I no longer have any errors. Just took a while for search console to recognize my edits.

Got it, thanks so much!

SEO video indexing issue: ‘No Thumbnail URL provided.’ Ensure proper optimization for better visibility and engagement.

To all of those who are experiencing this problem, there is a wishlist post that can be voted for in the hope that Webflow might consider it and do something about it. Vote away.
https://wishlist.webflow.com/ideas/WEBFLOW-I-5750

When we received email from Google Search Console even we didn’t able to solve this until we make below change

To add a thumbnail for a background video in Advanced Elements in Webflow and fix ‘No Thumbnail URL provided’, you can use the following steps:

  1. Create a new div block and position it over the background video.
  2. Add an image to the div block.
  3. Style the image to look like a thumbnail.
  4. Hide the div block so that the image can’t be seen.
  5. Once the publishing the site, go to Google Search Console **>**Indexing > Video pages and validate the fix.

4 Steps to Resolve No thumbnail URL provided in Webflow