Section anchor links not working on published site

I’ve combed through all of the related posts with no luck. I have tried putting the Nav element in a div block, removing the fixed position, disabling all interactions, etc.

The anchor links work well in preview, but not in the published version. If you open the link in a new tab, it works. So assuming it is either bug, or the settings of one of my containers.

Here is my site Read-Only:


Site URL:

It may have something to do with your custom CSS, although I can’t be sure without removing it and republishing the site. Have you given that a try?

Good thought! I did try deleting all the custom code. Right now it is just slider styling and max container width, I have used both on other sites and not had this issue.

I also tried deleting the container with the hero interaction component with no luck.

I also tried dragging in a new nav component with no changes to styling, and targeting a link to a section, and it didn’t work. So I don’t think it is an issue with the header module build/components.

One thought, the body is set to Overflow: Scroll because there is an issue with it not scrolling if it is set to Overflow: Visible. I am assuming that has to do with the hero code embed, but there is no work-around at the moment.

Yeah given the issue with the scroll I would lean towards the issue stemming from the hero code embed. Since it’s working in the Designer but not on the published site, it’s something that’s not being rendered within the Designer window that’s conflicting with the anchor link scrolling used by Webflow. The only things I can see that aren’t currently being rendered are the hero embed code and the custom styles within your homepage settings.

Can you try eliminating both of those elements and testing again? The effect from the embed is cool but I’m leaning towards that being the problem child here.

I had a good look too, my best guess is also to test without the canvas script and disableing all animation interactions for the sections. Code-wise this should work, I guess something is preventing the default behavior. There are some Event Listeners on the canvas that might interfere!

You can save your current state as a named backup and do the changes there! If you want to revert, you can simply chose the backup in the project settings and all is there again. No need to manually add everything back in.

Have you set a base href in the project settings? Those do mess with anchor links, I am not aware of a <base>tag in the header though…

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.