Scroll to section links not working on published site

Hey Guys,

I’m having an issue where my scroll to section buttons (in my header nav) work in preview mode, but once I publish the site the links don’t work at all?

Any help would be greatly appreciated!


Read only link here:

Hey ho Dylanbyfoster!

Thanks for asking :slight_smile:
I see that you are using a smooth scroll library, however - your implementation is throwing a lot of errors!

Webflow provides a way to scroll automatically to anchors (meaning ID’s of elements).
First, give an element that you want to be scrolled to as an anchor by giving it an ID. You can do that in the “Element Settings Panel (d)”:

image (You already know that!)

Now you can select that element as a target in the link settings of any link text or link block:

If that link is klicked, the page scrolls to the top of that element!
You can only select anchors on that very same page!

Try implementing this first, without using the smooth scroll, this library overrides the browsers viewport position constantly.
Also, you are importing two different scrolling libraries, I’m not sure this is intentional? It seems they don’t work very nice together, try only using one!

Hope this helps a bit :slight_smile:

1 Like

Amazing, thank you @RDaneelOliwav. You’re solution has worked :slight_smile:

Glad it worked :slight_smile:
Looks real nice, what you crafted there!

It’s probably not done yet, but your home link in the nav does not redirect to the home page on the service page

The console still logs errors on every scroll:

Try updating the jquery.scrollify.js to version 1.0.20! The error is probably due to a recent update in chrome.

If your original question was answered by me, I’d be happy if you marked it as the solution <3

Keep up the good work :slight_smile:

Hey RDaneelOliwav!
I’m using the exact same method you described to link my sections with my NavBar links, but when I click the link, it does not scroll all the way down to the section, it gets stuck halfway down the page.

I’ve been looking for a solution to this problem but I couldn’t find any, hope you can help me and others with the same problem.

Thank you!

Just wanted to add that I am also having this issue on a long case study page for my portfolio. I turned element animations off to make sure all content was visible on the site but for some reason, my anchor links for the sections further down the page only scroll partially. I have to press the button a few times before I reach the section.

UPDATE: I found a solution here - Anchor link scrolls to wrong area on first click but not second - #3 by outerwhitespace
Change your photos from “Lazy Load” to “Auto”. Now, my anchor links work perfectly. Hope this helps anyone searching for an answer in the future. :blush: