Streaming live at 10am (PST)

'Scroll in View Animation' only working on mobile when zooming out

Hi there,

I saw some similar issues on related posts, but couldn’t find a solution that fit this instance.

I am using the scroll into view Interaction, it works well on desktop, but on mobile I have to zoom out on the device for it to trigger.

I have seen some tips on making the container 100VW or making sure overflow is hidden, but it hasn’t worked. Currently “Section 01” in the stack has the interaction enabled, and is set to those specs. Not sure if this is a bug, or an issue with my settings. I am building another site currently with the same interaction and am not having that issue at all.

If there is a relevant post that answers, I apologize, please direct me to it and I will explore.


Here is my public share link:
https://preview.webflow.com/preview/anon-home?utm_medium=preview_link&utm_source=designer&utm_content=anon-home&preview=a69649d9b4d24172b15c03d70211ac58&mode=preview

iO Link
https://anon-home.webflow.io/

Any thoughts on this?

1 Like

I have the same problem but my nav just doesnt work on mobile at all. Did you find a solution?

It isn’t showing due to interactions or just not showing at all? There is usually a display setting or a container setting that will be a solution.

One possible solution I have been using in terms of mobile menus, is creating a new menu that displays only on mobile, and hiding the desktop menu. That way you can create a more simple container solution that isn’t a heavily modified version of the desktop. A bit more cumbersome with changes, but if you use combo classes it alleviates some of that.

Since my site was only a landing page, I can double check, but I believe I just cppy pasted and built in a new project and it fixed.

This was one of the few things, in terms of interactions, that seemed like a bug and not user error.

So one thing I realised is that for some reason some of my properties didnt carry over to mobile and when the nav should have been fixed it was static. It now shows when scrolling, but it does not dissapear at the very top so trying to see what is causing that.