Streaming live at 10am (PST)

Removing CMS error


I have adjusted one of the free templates into a website of my own. Now I need to delete the CMS collections because I want to upgrade to a paid basic plan but unfortunately I can’t delete the CMS collections. I have deleted all the items inside, checked all my pages and deletes all the unused tags and nowhere should there be any CMS elements still active but I still get the “Cannot delete this collection as it is used in bindings” error.

Can anybody tell me what I still have to do to make this work? I’ve included my preview link below.

Hi @Jorik,

I found a CMS reference in one of the dynamically generated page Templates for the CMS.

If you open your pages window and scroll all the way to the bottom… You should see it right down there. Try deleting all CMS references from these pages. Including the lists with empty states. Let me know if that works. Preview Mode was being a little bit wonky…

Worst case you could wrap everything inside of a div and copy and paste each page over into a brand new project.

Hi @austin, that worked on one of those CMS pages, but not on the other unfortunately. I have completely emptied those pages (there is only a “body” left). Any ideas why I still can’t delete that CMS collection?

Or anyone else of course…

Hi @Jorik,

Just looked at it quickly again… I can’t see anything that should be causing this. If its still giving you issues and you are sure that you have removed all CMS references than I suggest getting in touch with Support.

​I pinged a team member (@bart) and he was able to pinpoint the issue here. It looks like your Blog Post collection is being used in the symbol: Sidebar

​Here’s a quick video with more detail:


​If you delete that symbol you should be able to then delete your collection.