Publishing a new page

Hello, I am new to Webflow and (mostly) self-taught. I am trying to publish a new page that I copied from a current page, and then I would like to unpublish that current page. Can you help?

Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Hi Kristen, if you share your designer readonly link and explain which pages you’re trying to change I can be more specific. Instructions are at the bottom of your post.

Basically, let’s say your page is /about

  • Change the slug of your old page to something else, like about-2, and mark it as draft
  • Change the slug of your new page to about
  • Check for any automatic 301 redirects that may be created in your site settings
  • Publish your site

Hi Michael, I just added it. Thank you!

I don’t know which pages you’re trying to supporess, but if you open page settings, you’ll find draft in the dropdown by the Save button.

Looking for the drop-down now…

Something else is going on since it can’t find the page. Heading to a meeting and will log back in later. TY!

When I put that page in draft, it does take it down. How do I publish the other page? It’s not connecting to the nav. TY

You just publish your site. Your nav needs to be linked to your new page if you haven’t re-linked it yet. It connects to the page, not the URL.

Thanks. I have relinked it to the nav, and put the old page in draft, and have pressed publish multiple times and it’s still publishing the old page. Would it be linked somewhere I am not thinking of that would overwrite this? Thanks

What page are you trying to publish, and what page is drafted?

Current page that is published, but I want it to be drafted. When I draft it, and relink to the other page, the page goes missing from the live site

This is what I want to publish

I think you’ve missed this step here-

If you check your site settings redirects I’d guess you have a redirect like

/contact → /contact-achive

Delete that and republish. Webflow can automatically create these when you rename page slugs.

I didn’t know about site settings–thanks for that. I deleted them and it’s still not working. In site settings, this is what it looks like:
/contact.html > contact

For every other line, there’s a slash in front of the word so I think it SHOULD read:

How do I get it to do that? When I publish, it says it’s a 404 error

Nice, I can see you’ve deleted this one- /contact → /contact-achive.
Your others aren’t related, but yes, the /contact.html → /contact would be correct, not → contact without the slash.

Everything you’re saying makes perfect sense and I appreciate the vm. However, I promise I have done everything you say and the new page will not publish. When I check the site, it comes up with this:

that’s not the page I have directed it to. What else could it be?

You’ve got it.
What you’re seeing is just a cached redirect in your web browser.

Try it from your phone, you’ll see that it works.

oh my gosh. it’s been working since yesterday and i couldn’t see it… wow
thank you!

1 Like

New question: Now that I have a contact form, how do I direct it to a specific email address at my studio? TY!

Check site settings, under the forms tab.