Streaming live at 10am (PST)

Problem with displaying cyrilliс fonts

Hi! Got a problem - i’m using webflow on Windows XP/7, Chrome and i’ve installed a few of cyrillic Google fonts, BUT none of them is displaying within a Webflow (exсept “Lobster”). When I change the font - nothing changes, instead of all these fonts is displayed only Arial or Times new roman.
How this can be solved ? I

Want to add: cyrillic fonts are just not rendering in the design mode, when i export they works fine

Hi @djyolan, can you please provide the name of the cyrillic font you are trying to use so that we can reproduce this issue? Thanks!

Maybe you’ve changed something from yesterday? Now i got some of my cyrillic fonts working, BUT these are still not working in design mode: Tahoma & Verdana (shows the same font) and Philosopher.

I have same problem with next font:
Roboto Slab
PT Serif Caption
Roboto Condensed

That’s really odd @djyolan and @ritini. We’ve added this issue to our bug list and we’ll look into why this is happening.

@djyolan just to get more info on this issue, it takes a day for the font to show up after you have published or does it work instantly after publishing? Also, when you have Tahoma, Verdana and Philosopher selected in your list it shows the default font Arial in the designer?

Oh, cyrillic font dont work in design mode, but work if I published my project. In design mode only Cuprum work ok. A cant tried other cyrillic fonts, if they will dont work, I post message in this thread.


1 Like

Hello, have you found a solution?

@RomaRio - just released a fix. Could you try and see if everything works as expected? Default fonts (the ones that get included) still don’t have cyrillic support but they should work for other Google fonts that you’ve set up.