Pages blank on published site, but working as expected in preview. Home page displays ok published

My site was published and working as expected. Now the only page that displays is Home. All pages are working as expected in preview. No changes in custom code were made. It is a basic static site. My guess is that I ran my VPN by mistake while webflow was open. Chrome inspector is showing these errors.


Here is my site Read-Only:

https://preview.webflow.com/preview/usable?utm_medium=preview_link&utm_source=designer&utm_content=usable&preview=a340efbee7e52dd669e1091305231de3&workflow=preview

Hmmm, without taking a peek at the published URL it’s going to be hard to debug this one but it definitely seems strange considering you’re not using any custom code.

I’d probably recommend un-publishing and re-publishing the project to see if that helps sort out any issues that may have happened when it was being compiled. I doubt the VPN would be the culprit, but just in case I’d suggest keeping it off during the re-publish :wink:

All pages except the home page are now 404.

I am guessing something happened in the publishing process. My vpn was probably on and that caused some problem. I never use a vpn while working with Webflow. I just forgot to turn it off.

I’m only seeing a 404 on your About Me page (although it looks like it’s linking to “/my-story” when the page is using the slug “/about-me” in the Designer)—the Marriott project show up just fine on my end with the other pages showing a blank page.

It also looks like you are using a bit of custom code (both Luxy and a JS delay for the page load animation), but I’d doubt those would cause the issue. One thing I do notice is that some pages are calling the “page-fade scale-in” interaction when the page finishes loading, while others call it when the page starts loading. Interestingly enough, pages that aren’t “loading” are using the same interaction setup as pages that are.

Hopefully an un-publish and re-publish smooths out those quirks, but don’t hesitate to reach out if they’re still present afterwards.

I will correct the page load interaction discrepancy, and the linking slug mistakes.

I have it working at the webflow.io address.
Marriott Case Study

Unpublishing and republishing at usableco did not resolve it.

I will go through the pages and remove the luxy.js. It should not be there.

I corrected the errors you found. The interactions and the link slug. Unpublished and republished to both locations and I am getting 404 for everything but the home page. At both published locations.

Hmmm, I’m not getting any 404’s on your live site, but it looks like the pages that aren’t loading are just not firing the necessary JS to make them visible—if you check DevTools they are loaded but are just set to display: none:

image

I am seeing a lot of errors on your case study pages, but those look like they may be caused by the embeds you’re using possibly timing out.

Thats what I thought. I don’t know why. I looked and nothing is set to display none. Every thing is correct in preview.

You are thinking that removing the google drive embeds will solve the problem?

The sitewrap display none is part of the page load animation. So I am guessing something about the embeds is preventing the the rest of the page from finishing the load.
?

I can’t say for sure as your about page is having the same issue and it doesn’t include any embeds like your case study pages. You could try recreating the interaction to see if that helps, and I’d also recommend that you split it up over both when the page starts and finishes loading instead of just one or the other.

Essentially you’d have it show the off-white color with the page content hidden when the page starts loading, then when it finishes you’d animate the fade up. I can’t really say if that’s contributing to your issue, but it’s probably worth changing to keep things clean.

When did the page issues start appearing? Did you make any significant changes to the project that made things stop working?

Everything was working and then I started making the changes to the body’allpages’ font size for smaller breakpoints. The publish problem showed up then.

Shouldn’t I be able to restore to a version proceeding the problem?

I will make the changes to the interaction you mentioned.

Thanks

Shouldn’t I be able to restore to a version proceeding the problem?

Yep, that’s another option (assuming you haven’t made too many large-scale changes since the problem started) so depending on what’s been worked on that may be the best bet.

All the pages of the restores other than home are 404. This can’t be something I did in the designer. I have started a new project and copying everything over. I’ve built a number of sites with Webflow and nothing like this has ever happened. If it were for a client I would be in a bind.

I figured it out. It is the links url. I should be using only the slug. I have the url & slug. Removing the url fixed it.

Glad you were able to get this figured out!