Streaming live at 10am (PST)

Opened cart stuck within nav symbol

Can anyone explain why this would be happening to my cart? Once opened the cart wrapper seems to only be present within the header symbol however the text does appear still

Hey Tristan,

Can you share a read-only link with us? so we can “see under the hood”…

as you can see its quite messed up. only thing that makes it work is putting the cart within the body. Ive tried unlinking the header from the symbol as well and that yielded no results.

heres the read-only linnk

Why won’t you have it under the body?

Because i would like it to be available everywhere, its fairly common practice to keep your cart within your navigation. I guess i would be able to position absolute it but then I would be doing that for every page and doesnt seem very DRY

It is actually under the body as well. its just contained within a div within the body. There shouldnt be any issue with that. I may switch to Shopify api if this bug is not solvable currently, seems odd that its not though.

Its almost as if the cart wrapper is 100% height and not 100vh which is a tiny mistake that Im not allowed to change in the designer.

I actually cant even position the cart wrapper. I feel this is a huge problem in general. The cart should be fully customizable should it not?

1 Like

heres an example

why is mine not working?

Hi Noonmoon a lot of webflow components are not customizable themselves. The material with in them is. You can visually place the button in the place you want using positioning. But it looks like that cart is designed to be in the body so that the opening function operates properly. The cart looks like it only has a few options for opening. Modal,Left, Right. These custom components are created to make it easiest for most use cases and in a way that it is hard to break them. What are you trying to do with the cart that it is not letting you do?

Thanks for the reply, I am simply just trying to put the cart within the navigation. If you checkout you will find every site listed here has their cart in the navigation and it works perfectly. However doing the same thing i cant achieve those results.

Okay I see that. It has something to do with how you designed your navbar.
I just tried to put a blank navbar in and added your card to it. It works. I couldn’t tell you what exactly was done with the first one. Sometimes the easiest solution is to start with base components and then style them. I have had to redo bits because of that in my own work.



Thank you!! Just started doing the same thing actually. Someone elsewhere told me to create my own navbar because the default ones so buggy. Guess theres a few bugs without it too lol. Not sure what caused this either but I should be able to start from scratch and fix it now thanks again.

Might not actually be the nav but something in the header section. Margins or something because I moved the fully functioning navbar into there and it stopped working. I see you are already in there. Creating a custom nav works too. what a lot of people do is remove the container from the navbar. Then you don’t have the restrictions.

Was thinking about that. just created default nav then moved nav-menu into another nav container I made. Works good now!

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.