NOINDEX tag not working on collections page


I have testimonials pages on my website. The testimonials are collections page. I’ve enabled the option to exclude them from the sitemap, HOWEVER, the individual testimonials are still present in the sitemap, as well as are missing a noindex tag.

Any advice?


If you want to block pages or collection pages from being indexed in search engines you need to handle that yourself. The indexing Webflow is talking about (option in page settings) is the internal search engine used when you implement search on your site.

Okay, thanks for that.

Would it be through robots.txt or there’s another way? Sorry for asking, I’m not a webdev (I’m the SEO).

It would be through the meta robot noindex tag in the head area of the page.
For collection pages, you still need to generate that manually.

You’ll find this well covered in Google’s SEO docs.

1 Like

@Llamarketing made a quick loom for you.

For some reasons I can’t open your read-only link.

Here’s the line of code:
<meta name="robots" content="noindex">

Thanks to everyone for the advice!

And especially to Chris! The loom helped me a lot and made things very easy!