Need Help with Footer Text

Hello, I have some strange formatting going on in my footer text, but only after I published the site, and it’s only showing up on my ipad and iphone. I’ve attached a screenshot of what it looks like on my iphone. It doesn’t show up in any of the mobile preview options.

The phone numbers are black and there is a couple extra blank lines between the phone numbers. The phone numbers are links, when you click on them on an iphone, they ask if you want to dial the number but I didn’t set them up to be links. Does Webflow automatically recognize phone numbers and format them for iphones? I did set up the email as an email link but the phone numbers should just be text. They should be spaced the same as the address block.

As far as I can tell, there isn’t any special formatting or combo classes added to the footer text with the phone numbers, and I selected the phone numbers and clicked the clear formatting icon just in case, then republished and I still get the same thing. It’s probably something I’m missing but I don’t know what else to check.

Thanks so much,


Here is my site Read-Only:
(how to share your site Read-Only link)

Hey Annette.

Can you share a link to the published site?

It’s website is


This might be a formatting problem.
Try copying the text from the ‘footertext’ element to a notepad and remove all formatting. Then copy it back to webflow.

No that didn’t work either.

Then, I deleted that particular block, and started from scratch dragging a text block into that column and just placing some text in it. Republished that, and the words looked fine and spacing was fine. But when I entered any series of numbers, I even left out the dashes, it recognized the number as a phone number and automatically made it a link. It also turned it to black which doesn’t work well with my dark blue footer background.

So, it’s recognizing numbers as a phone number, even when I put the word Web in front of the phone number, it treated the numbers as a phone number.

This is strange; could this be an iPhone thing? Is there maybe a setting in the iPhone that says, read numbers as phone numbers? I noticed the phone numbers outside the footer, on one of my other pages, are showing up as phone number links, with too much spacing in between also.

If you look on the Ice Alert Products page, at the bottom there is a distributor in Europe, his numbers are underlined and links on the iPhone but I didn’t do that in my design.

Any ideas?


A simple google search got me this:

Ok, thank you so much for this information. I use Safari on my iphone but installed google and sure enough, it looks fine so Safari is seeing those numbers as a phone number and, I guess applying it’s own formatting. I wish they would let me do it!

So, not being a coder, would I put that line of code in project settings - footer code?

Wow, so helpful!


meta tags should go in the <header> of a page or project.

Hi Avivtech, I’m so sorry for not getting back to you sooner, I’ve been away for a couple weeks.

Adding that code to the header worked perfectly! It is now the right color and the correct font on the iphone.

Thanks so much for all your help.