Streaming live at 10am (PST)

Navigation Symbol not working

Of course! :slight_smile: Thanks for the quick reply. I think we’ve got a fix… we’ll report back soon!

Hey Brando,

I don’t have any elements nested other than Dropdown’s which haven’t been an issue using Menubar. As of yesterday, everything worked fine…

Thanks much for looking into this…

Cheers!

that worked for me but I need the jump link to be on all pages. Would I have to work each nav bar manually then to be able to include the jump link?

@ON2Interactive thanks for bringing this to our attention! We’ll be pushing up a fix soon to hopefully solve the issue you are having with nesting a Dropdown inside a Navbar. We’ll keep you updated!

Thanks,
-Andrew

1 Like

@justjoe you should be able to keep it as is with our upcoming fix. Thanks for validating!

1 Like

Awesome! I’ll be on the lookout for the fix then. Thank you!

1 Like

Hello Webflow!

I think there may be a bug with the nav menu. Every time I try to copy-paste from page to page a navbar, or place a navbar symbol i created onto a page… I’m getting this error message. I know this is current functionally because I’ve done it many times before. Unfortunately, I cannot share a public link. Is this a recent known issue?

Thanks,
Dom

Hi, I want to copy and paste the navbar on the homepage to the other four pages, but when pasting on the other pages, the Design Tool kept preventing me from pasting, saying that ‘nav link cannot be pasted out of nav menu’.

I’ve tried pasting the elements in the navbar bit by bit / creating symbols, but none of it worked.

How can I solve this issue and copy and paste the navbar to other pages? Thank you for your time and help!


Here is my site Read-Only: https://preview.webflow.com/preview/yiningz?utm_source=yiningz&preview=0e18926876a94fab04645a14ef126920

Same issue here. Seems to persist whether it’s a part of a symbol or not. Other elements seem to copy paste just fine. It’s the nav link that’s giving me grief.

Thanks for working on this as always!

Hi @Riley @domo @yzhou

The issue seems to occur when there are existing sites that have no Navlinks inside the Navmenu or like @ON2Interactive there are only Dropdowns, (again, no Navlinks)

I’ve just tested a fix created by our amazing :webflow_heart: engineers which seems to do the job, and we will keep you posted as to when it’s live.

@justjoe you should be good to keep your jumplinks too :slight_smile:

I know how frustrating these bugs are in the design process so thank you so much for your patience and understanding :pray:

2 Likes

Thank you! As a temporary fix I added a navlink to my menu before copy and paste. Keep in mind, after this is done, I can’t remove the navlink from the new menu.

Capture

This will be a temporary fix for now. Thanks again for the help!

1 Like

Same here. Unlinked as a symbol and still not working for me on any of my sites.

I can confirm that my nav menu does have navlinks (and dropdowns) and still doesn’t work.

Thanks for that @Port_of_Folio, it it possible to share your read only link, or email it to mark@webflow.com so I can see if the fix will work.

Standing by for your reply :+1:

Absolutely:

https://preview.webflow.com/preview/sherrillfurniture?utm_source=sherrillfurniture&preview=38f933236fc2395f49ceddfc3d165fbd

I’ve unlinked the symbol on my homepage nav (doesn’t copy/paste) and symbol version on “New Items” page is same error.

Thanks for that @Port_of_Folio

So the links you have in your Nav Menu are not actually Navlinks they’re Link Blocks. So you have a Nav Menu without Nav Links which is where the issue is. (The fix should… well fix this)

A temporary solution for this…

  • Drag a new Navbar anywhere into your page.
  • Drag one of the nav links from the new navbar into your current one
  • Give it a setting of Display: None
  • You will be able to duplicate the navbar.
    (Delete the new navbar)

Video explanation:
CloudApp

I do appreciate this is not ideal, a fix is around the corner, we just want to make sure it’s A-OK before pushing it live.

Please let me know if you have any issues.

Ah! Sorry about that. I have my link blocks named “navlinks” and confused myself. This works now. Thanks… never apposed to hacking it :slight_smile:

No need! :slight_smile: Glad it’s working now :smiley:

My nav bar has nav links not link blocks but it’s still not working.

Read-Only Link >> https://preview.webflow.com/preview/stce?utm_source=stce&preview=bf2f1a4e6ba8a5c46a5cf38646b26f35

Hey @JustJoe The text span on the Vendor Contact link is being classed as a child of the Navlink ( I think) , which on this version is not allowed, although it should be.

The fix in question that I’ve tested solves this and will allow you to use the jump link once again.