Mobile version of homepage wouldn't scroll


My webpage won’t scroll on the homepage in the mobile version.

I have fullpage.js activated on the homepage

Read-Only Link:


Would be great to have some help/advice! Much appreciated

Hi @audrette,

Looks like your ‘fullpage’ section is set to hide in mobile portrait, which prevents this section to be displayed in mobile.

It also seems these settings are being used on several sections of your website:

Once you remove these settings, the page should then display all elements and scroll as expected.

Hope this helps :slight_smile:

Hi @audrette,

@Nita and I are tag-teaming today :blush:

I was also able to take a look at your project, and noticed that errors were showing in the Console as there were multiple instances of the JS library being referenced (site-wide, and on the page)

Feel free to remove the custom code that has been added to the page as the site-wide instance will work.


1 Like

Hi all, :slight_smile:
thank you so much for the quick responses! I really really appreciate it.

The reason why fullpage is hidden on mobile version, is because the plugin js I used from alvaro trigo for presentation like scrolling doesn’t work very well on mobile screens.

Hence I created a mobile-only DIV called MOBILE so the format looks different on your mobile!!

I was wondering in that case, how do I keep the two separate formats but fix the scrolling bug for the mobile version?

Hi @audrette,

An easier implementation would be to disable fullpage.js for mobile devices.

The following code is how it can be completed:
<script> if (screen && screen.width > 768) { document.write('<script type="text/javascript" src=""><\/script>'); } </script>

You can view this implementation at the following URLs:
Live site -
Preview link -

Hope this helps :blush:

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.