Mobile scroll not working

Hi, when I publish my site it will not scroll on mobile, I don’t have overflow hidden on any layer. The page scrolls only on preview but still doesn’t scroll on mobile when I put the body on the scrollbar but I understand that this is not normal to have to do this. Can someone offer me any advice?

Here is my site Read-Only:
([how to share your site Read-Only link][2])

Clear all the changes you made to the body position and set its overflow:visible


Thanks for your advice, i’ve done this and it doesn’t work. When I set the overflow to Auto the page scrolls on webflows preview, but when I publish the site it won’t scroll
To try on your phone the link is:
The preview link is:

Try removing all position styles from your body.

Hi Thank you,
How do you do this, it says the bodies position cant be edited?

alt+click on the position title (which is blue)

1 Like

It worked! Thank you so much !!

1 Like

Hey! I know it’s been a while since this thread but having the same issue with my landscape mobile mode (i fixed the portrait mode by setting overflow to visible earlier) but can you elaborate on what you mean here? My mobile landscape won’t scroll at all.

Oh I just realised it starts to scroll but ONLY if a touch the navigation bar and gesture my scroll from the very top of the page section…But even then the sections have been squashed. Any ideas why?

Can you share the live link to your website and the read-only link ? Thanks

1 Like

Thanks, man it was very helpfull…

1 Like

@media all…
.name of the head div {
overflow: scroll;
-webkit-overflow-scrolling: touch;