Streaming live at 10am (PST)

Long-standing problem with .html

Hello! I read other topics about the same problem as mine.
For example Internal links change to *.html after code export

When I select a link to a page by choosing from a list of pages and then exporting the code – I get links with .html (it’s OK and looks logical)

But when I write ‘/pagename’ in the link address and export the code – I get ‘/pagename.html’ again in the export (it doesn’t look logical, because I wrote the address by my hands, but it was replaced)

It would be much more convenient if the written links did not change after export. Give your users the ability to link manually.

Are you planning to fix this?

Thank you!

The reason is that without modifying the web server settings, the pages would not load. Web server would not know what to do. Links would be broken. Angry users would invade forums.

If you wanted to get ride of them you could just to a search and remove the .html extension on links in the HTML pages, after your configured your webserver to rewrite the .html via your .htaccess settings on an apache webserver. Different procedure on NGINX, or MS IIS would be followed.

Thanks for the answer!
But I think you did not understand me.

My problem is that when exporting the code, custom links have changed… (not selected pages from the list). How I can get links like ‘/pagename’ in export, if i want custom links?

I did two tests.

Added a two links to a page using the “text link” object.

One instance used an external link pointing to /Home
result on export: <a href="/Home" class="link">Text Link</a>

One instance used an internal page link pointing to home (name of my home page)
result on export: <a href="index.html" class="link w--current">Text Link</a>

So we can see that on an export, external links do not get changed. Where internal links (pages and sections) do. Which is the default desired behavior.

Which one of these matches your issue? Or do you have a different example you could share?