Landscape not working and using desktop site

As I said, using the landscape version doesn’t work and ends up using the landscape mode. (Btw go to 1998 page) I know it’s using desktop because the overlay I setup to block the page isn’t working. I only have a free site plan so is there a way I can fix this issue?


Here is my site Read-Only: Webflow - NNSG

Hey @Raku_Biggu

Can you give little more information about what you are trying to achieve exactly?

Thank you :webflow_heart:

I’m working on a windows 98 desktop and I disabled it for mobile devices however when I test it out for landscape, it seemingly doesn’t want to show the “go to desktop” message I have setup it (which works perfectly fine on portrait mode). After messing around, I found out that the desktop was being used instead.

I see the message on both breakpoints.

You don’t see this message on landscape?

that’s what I was referring to, I just forgot the message. but the message doesn’t appear

So you want to have 2 separate messages? One for landscape and one for portrait? Sorry but I can’t clearly understand what you are trying to achieve.

The current issue is that landscape mode doesn’t even work in the first place. It displays the desktop site.

Have you done any changes to landscape mode? If not the styling will be inherited from the parent breakpoint.

I’ve done changes to try and get the website to work but scrapped it due to it being near impossible. So I made the overlay to disable usage of it.

So, from what I understand you weren’t able to get it working on landscape and you want to show the message for mobile right? This doesn’t mean landscape isn’t working. All changes you make will apply to landscape.

Do you want to make it work on landscape or you want to show the message?

test it on a phone, when you tilt it into landscape, it doesn’t do it. Landscape technically does work but it doesn’t appear on devices.

Tried to open, but with no success. Can you share the staging link?

Sorry for late reply

Hello @Raku_Biggu

What kind of phone are you using? I can see the problem on iPhone 11 pro max, but not sure if that’s a problem. I think the landscape just inherits the tablet breakpoint.

I think adding a custom breakpoint via code will solve the issue. The current tablet breakpoint changes at 768px, but my iPhone 11 pro max is wider in landscape. I think 896px.

You can check this video > Webflow Media Queries - YouTube

Hoping this will help you :webflow_heart:

Did you got the solution?