Streaming live at 10am (PST)

Issue with mapkit map embed

Hi all!

I’m trying to embed a Mapkit map using the html embed, and I keep running into one of two problems.

When I export the code, I get options for ‘source code’, ‘iframe’, and ‘oembed’. When I select the first, I get a warning that the code is over 10,000 characters and too long. I tried minifying it to see if that would help and it’s still too long. When I select either of the latter two options, I get a 404 error.

I tried doing it in the custom code under project settings as outlined here:, and it went off the rails in step 8/9 and wouldn’t work.

It might be helpful, so here’s the iframe code: <iframe src="//"height="600" width=“1000”>

and here’s the oembed:
version: ‘1.0’,
provider_name: ‘Mapkit’,
provider_url: ‘’,
map_url: undefined,
mapid: mapkit-6029,
height: 600,
width: 1000,

I’d love any suggestions you all may have for how to make this work.

For an iframe to work, the URL inside of the iframe code must resolve.

Your URL, , doesn’t.

I guess iframe is the way to go for such an embed, but there’s a problem with the code they give you, obviously.

I made some tests, half of the site is down and return 404… I can’t reach the home each and other time and can’t reach the editor at all. So, maybe not your fault, just the bad day to work on you mapkit :slight_smile:

Gotcha, thanks! I tried loading it myself and got a 404, but it’s my first time using mapkit so I’ve been kind of scratching my head. It seem really easy to set up but there’s very little documentation or support, and it at least today, it was very glitchy so I’m not sure what to make of it.