Streaming live at 10am (PST)

Images on hover not working properly?

Each project has a “Next project” feature at the bottom of the page, with an image showing on hover. It worked properly until I messed it up somehow and I don’t know what features do I have to change to make it work properly again.

Any ideas? :thinking:

Here is my site Read-Only: [LINK]

Maybe it has something to do with this empty state?

I think it’s rather some feature from style or settings. It was working perfectly fine before, I’m not sure what I modified to lose this feature. Images are correctly linked from the CMS collection, but when I hover now, the picture does not appear as it used to.


So, apparently, hover image is actually there, but in an awkward position. I tried changing from static to relative, absolute and fixed positions and messed around with the margins, but the image still appears to be displaced on hover.

Any ideas?

I’m assuming the tooltip image that is activated at hover appears somewhere below the site limits and pushes the text creating this very annoying situation. (I recorded my screen for this one, but I can’t seem to find an option to share a video to this forum?)

Hello @aran_hrzn,

First I just want to say that your website looks awesome, great job! The issue that you have has to do with the interactions that you have for your element tooltip.
Screen Shot 2020-01-20 at 11.41.01 AM
The mouse move in viewport interaction makes the tooltip to go to the far left corner when the hover interaction is triggered. It would be a little tricky to fix if you keep both interactions at the same time. I would suggest you to delete the Mouse move in viewport interaction until you find a fixed position for your tooltip within the parent container. Then after the hover animation works, add the Mouse move interaction. I hope this helps.

1 Like

Hello, @Pablo_Cortes! Thank you for your input. I removed the move in viewport interaction and now it works smoothly. The thing is everytime I try to replicate the move in viewport as it worked before, it messes the whole thing again. So I’m using a simplified version of the effect and (sadly) got rid of the mouse response.

1 Like

Hello @aran_hrzn,

I’m glad it worked for you. The move in viewport I found to be a little tricky to use, specially on something like the effect you want. Have you tried making your section the trigger point? In my experience the trigger point always makes or brakes the mouse interaction. Good luck!