I can't remove fallback fonts

Even if I remove all custom fonts from the project settings and from the project, when loading the final page, the browser loads 13 fonts. Even the ones I never used. Please Help!!


Here is my method Read-Only: Webflow - Copy of PIANOHOF

Here is live site: https://pianohof-64ed7a0c5faa44fd946eefcb84f7d5.webflow.io/

hi @PIANOHOF when you read you second screenshot you fill find your answer simply said these are fallback fonts (whole family) loaded by Webflow

CleanShot 2022-01-24 at 21.49.47

more info can be found here. Fallback fonts are in last section

Hope this will help you understand about these fonts

Hi @Stan
The screenshot shows that the browser loads at least 10 identical fonts under the Lato family. They are clearly not reserve. I doubt they are needed at all. Why and where did they come from and how to remove them?

hi @PIANOHOF please read article I have posted or look closely into your settings. Here are fonts you are do not know from they come. They are AUTOMATICALLY set by Webflow.

https://drafts.csswg.org/css-fonts/#font-display-desc

Last link is to W3C (World Wide Web Consortium) that is responsible how and what is used on web, simply said they do all rules for web. You can read their explanation about fallback fonts.

Hope that will help you to understand what and why. :wink:


EDIT: here results what is loaded on your page

one font Family lato

Hre what you see when you look on loaded fonts.

plus your custom fonts

That you see link to whole family doesn’t mean that family is loaded many times. Each link is for one font style

this is my custom font (Lato) which i removed from the project settings. and even if you delete everything in the project, 10 fonts famili Lato are loaded. this is clearly not the norm. But it does not matter. the question is how to make sure that the fonts are not loaded in such quantities. because of the fonts, the site loads many times slower. And as I see it, the lato font family is being loaded.

I see that Lato fonts are in <head> (viz image in previous response) So there should be used somewhere. I can see your read-only as WF is down. All read-only giving 404 already around 2 hours.

@Stan
thanks for the answer!!! I will experiment more tomorrow. I also noticed that after removing the custom font from the project settings, it is still in the list of fonts in the project. Is it normal?

hi @PIANOHOF once WF will be back I can look into your project to see what is going on. But It is early morning here so I go to sleep and be back about 8 hours. :wink:

hi @PIANOHOF when I’ve opened your project first thing I saw is that you are using Google Lato fonts. So they are automatically loaded. Problem solved.

Hi @Stan ! Thank you for the help!!! I updated the project. It was problematic to remove the font, because I had to check the font in all tags and objects on all pages of the site. Just removing the font from the settings does not work. Hope the developers fix this. At the moment, unfortunately, the Lato font remains in the list of fonts and I can’t remove it from the list.

Since I would like only used font styles to be loaded on the site, i loaded the same font using the correct settings and a different name. But I had to give the styles different font names. Otherwise it has no styles. Rather, the styles appear as they load, but they do not visually differ. The font was downloaded from google-webfonts-helper.herokuapp.com in woff2 format.