How to remove "current" subclass that is auto added when I add page link

I created a custom menu without using the “navbar” element and everything is functioning correctly on the home page, however it doesn’t seem to operate the same when I’m on the work page. I noticed that when add the page link to the home button on the work page it automatically adds a “current” subclass (or is it more accurate to call it a state) that is highlighted in green and changes the appearance of the button and I cannot remove the “current” subclass. Clicking on the “X” next to the subclass doesn’t do anything. The only way I have found to remove it is by removing the page link. It seems to work as expected for the work button, but for some reason it doesn’t work on the home button.

Can someone help me understand what is going on? Why am I not able to change it?


Ok, I think this might just be a bug. When I click my own link that I just shared, it’s working perfectly fine. Well almost, the contact section is showing and it shouldn’t be until you click contact. Clicking on home and then going back to work and it goes away. But when I’m logged in and working on my site and click on the preview site button, I get the problem again as stated above.

I’d disable all browser extensions, and clear your cache first, to see if something is interfering.

Thanks. I just tried that, but it didn’t help.

I’ve never encountered this issue but there have been a few posts here of people who are having struggles with the Current indicator, particularly when using localization.

Have you contacted support yet?

I should probably say that I am on a Mac and using safari. I also just tried google chrome and noticed some other weird things going on that weren’t there with safari. Like not being able to open or close the contact section and the overlay not showing up when you hover over my portfolio. I don’t know, I’m pretty new Webflow and web design in general and not sure what to do.

I have not reached out to support yet, but I can try that.

Thanks again.

Did you solve it? Because I am dealing with the same issue.