How to enable line break in CMS paragraph?

Hi All,

I’m new in Webflow and I need your help. I need to set big paragraph into CMS Collection with line breaks as you can see below:
tempsnip
However, when I put it into CMS and pulled it over I don’t have any line breaks:

Can you please help me?

Hi Aleks. Just throwing out a guess here – are you using the ‘Rich Text’ element or ‘Regular Text’? I made sure to test both in a project of my own, and feel like this might be your issue. You’ll have to convert to Rich Text elements to add line breaks as you describe here. I played around with the Regular Text element and couldn’t really find a workaround for this.

Hope this helps. If not, feel free to drop a read-only link to your project so I can take a deeper look. (Instructions here)

Hi Chris,

Thank you for your feedback, I really appreciate it.

I used Plain text - when I tried with Rich text, I am not able to find it under list: image.png

Any thoughts?

Thank you very much!

Sure! So, because you don’t have Rich Text element in your CMS, it won’t be available in this list.

You’ll have to do the following:

  • Head into the settings of your CMS database.
    CMS settings
  • Click “Add new field” and choose Rich Text.
  • Give the field a name, then click Save Field, and Save Collection.
  • You’ll then need to head into each individual CMS item you have and copy the contents from your Plain Text element to the new Rich Text element.
  • After you’ve done this, you can add a Rich Text element in the Designer, and choose the newly created field from your CMS.

Hope this makes sense!

Yes, it makes sense and I already did that, but my Rich text field still doesn’t show up in the list. Is there any additional configuration?

Can you share a read-only link to your project so I can take a look?

not available in the moment

Thanks! Assuming the final-decision-par element is what you’re trying to include your line breaks in, this is a Paragraph element. This needs to be replaced with a Rich Text element, because the Paragraph element does not support line breaks like Rich Text will.

So, you’d replace this:
image
with this:
image

Once you do that, you’ll see you can choose your Rich Text elements from the CMS (currently named test and Test 2. You’ll need to add the content to the rich text element inside the CMS, and once you do that, you should be good to go.

1 Like

Thank you very much, it helped… I really appreciate it!!

All the best :slight_smile:

1 Like

Awesome! If you don’t mind, can you click the “Solution” button on my post above so that other users that stumble upon this topic later and have the same issue know where to look? Thanks!

Just add a < br > to the HTML without spaces.

Hey John, I had the same thought as an easier workaround but the Text and Paragraph elements do not parse HTML, so they have to be rich text.