How to enable HTTPS / SSL on Webflow hosted website

I’m still fairly new to webflow and website building. I recently learned that I need to have SSL installed so my site is secure. Right now its HTTP and needs to be HTTPS. Had several people refer letsencrypt.org because it’s free. I currently host through webflow and my domain is with godaddy. Godaddy wants $80 per year for a cert. I’d like to use this free service if I can but it’s VERY intimidating as I don’t understand the first steps. LOL It’s asking questions in a language that I don’t even know what they are asking.

Hey again Sally!

If you’re hosting in Webflow, then you can just go to your Project Settings to enable SSL.

See this article here: https://university.webflow.com/article/ssl-hosting

It looks like this in the Hosting tab (towards the bottom):

You may need to disconnect your domain from your Webflow website first, toggle enable SSL and turn it on, and then reconnect your domain. (See that article above for more information.)

In short - SSL (HTTPS) is included already with Webflow Hosting! Just follow the article and you’ll be good to go.

Hope that helps!

1 Like

That was what I did originally and then this happened. So I thought I needed to take another step. If I turn SSL off, that “issues detected” goes away.

Hmm… Did you enable SSL after you had already connected your domain?

Yes. It was working fine. Then I clicked on SSL, it did this. Maybe I should contact webflow support?

You should only need to update your DNS settings at this point and you’ll be good to go!

Check this article out here: https://university.webflow.com/article/connecting-a-custom-domain

In short, SSL websites and non-SSL websites have slightly different DNS settings.


With SSL enabled, you should have the following DNS records:

2 A records:
@ → 34.193.69.252
@ → 34.193.204.92

1 CNAME record:
www → proxy-ssl.webflow.com


If you have SSL disabled, you should have the following DNS records:

2 A records:
@ → 23.235.33.229
@ → 104.156.81.229

1 CNAME record:
www → proxy.webflow.com


1 Like

OK. Well that worked on the creative-clicks but didn’t work on the www.creative-clicks. LOL

IT WORKED! I guess I had to wait a minute. Thanks for the help! You saved me hours of time.

1 Like