Hide/Show Navigation Selectively Works? IX2 Help

I’m not sure how to explain this other than I have built a navigation called “Navigation Scroll” that is supposed to show on the page as the user scrolls down and then hide when they scroll back up. I built it with the new interactions, and, when doing the live demo it works beautifully.

However - it doesn’t work in preview or on the published site. Am I missing something? There are times it works just once in preview. Then if I go edit other things and preview again, it no longer works (this is why I say selectively works).

Thanks in advance for your help!

Here is my site Read-Only: https://preview.webflow.com/preview/disasterpro?preview=c660f8f378036f5e563ad36e0a7b0c4d

You got two navbars that are exactly the same, Idk if that is what you want. Its a beautiful site though.

I have one that stays at the top, then as you scroll the other is supposed to scroll down into view (that is why you see it while editing but not in preview).

And hey, thanks! The client likes the look of it so far.

Ok I am not an expert or anything first of all.

Ok so you have your Main Navigation symbol set to the same animations as your Navigation Scroll symbol. I do not think thats what you want. The animations are (HIde, and New Scroll Animation). I do not think thats what you wanted but if it is let me know I will look more.

Hm… I’m not sure what you’re saying. the “Navigation Scroll” symbol is the only one with an interaction. And if you go look at it’s interaction settings, and do the live demo, you’ll see it is supposed to be hidden on load, then scroll into view starting at 7% and fully in view by 25%.

This interaction is not applied to the static navigation.

Ok let me look again. and even try and fix it for you.

Ok so this isnt that hard. I just want to know what you want. So you have a symbol called Navigation scroll. Is that the one you want to appear when the element Main Navigation dissappears as the useer scrolls back up?

Ok I fixed it for you. It was very easy, and probably just an oversight. But when you double click on the symbol Main Navigation and then go into New Animation Scroll. You have to set it to class, because right now you have it selected to Selected Element. Class will hide and show the Navigation scroll like how you want.

1 Like

I tried this and it still doesn’t work for me.

You said it works in preview but does not work when published. I do not know why. But hopefully you just changed that one thing that I took a screenshot of. It works perfectly for me.

Hi @szimmerman, just a note, there is a Page load interaction which is setting the navbar scroll to Hide and then when the page scrolls, the interaction is only moving the navbar, not showing it.

I would recommend to change the interaction to target the class as @Manuel_Canizares suggested AND delete this interaction:


I hope that helps.

I just figured that out myself.

She also has both elements to the same animation, you only need one from what I know since it targets the same one as long as you use class instead of selected element.

When I remove that style, which I did, the scroll navigation then appears when loading the site for the first time and disappears suddenly – which is why had on page load, to hide the element.

I figured it out myself, just needed to add that the element show up after page finishes loading. Thanks for all the help.