Hidden Fields in Webflow Not Passing through

Hi everyone,

I’m trying to pass a hidden field through my form. I followed the instructions in this post, but the value was not passing through.

<input type="hidden" name="utmSource" value="testing"/>

Value “testing” was not passing through when I look at my form submission log.

Any help would be greatly appreciated.


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Hey @Brooke_Spalding! Are you able to share a read-only link to your project?

Make sure the embed you’ve created is actually inside of your form.
Also, if you’re using a Logic bound form, this will not work. Logic needs actual elements in the form to know what to pass to the automation.

@blakelam Sorry about that! Here’s my read only link: https://preview.webflow.com/preview/fringe-dev?utm_medium=preview_link&utm_source=designer&utm_content=fringe-dev&preview=065ac34ea99e0bc26983a3f8f518a820&pageId=6660cde0de2707a1122340f0&workflow=preview

I don’t see your hidden field anywhere in your page.
You need to place that piece in an embed inside of your form.

Searching the code for it here as well doesn’t turn up anything-
Explore the Platform | Fringe

I do see an unrelated embed marked as visibility hidden, just in case you weren’t aware, that setting means it won’t render in the HTML at all.

Oops, I had been testing around and had deleted the html embed when you were reviewing. If you could take another look, I added the html and deleted the text field you were referring to, and it’s still not passing through.

https://preview.webflow.com/preview/fringe-dev?utm_medium=preview_link&utm_source=designer&utm_content=fringe-dev&preview=065ac34ea99e0bc26983a3f8f518a820&pageId=6660cde0de2707a1122340f0&workflow=preview

It looks setup right, and you’re using Webflow’s default form handler, you shouldn’t have any issues there.

However you have a recaptcha element, and it’s not configured for your staging webflow.io site, so you would not be able to test from there, the submission would be blocked entirely.

You’ll need to test it on your production site, or update your recaptcha config to include your fringe-dev.webflow.io hostname.