Google not showing exect meta description

When used website name on google google not show meta title and description which I show auto meta name and description.anyone can help me for this issue?

This issue should resolved itself within a week. Let Google the time to recrawl your site.

However, there are two other options. The first (and better) one is using the Fetch as Google option in Webmaster Tools. Here are detailed instructions:

Go to: and log in
If you haven’t already, add and verify the site with the “Add a Site” button
Click on the site name for the one you want to manage
Click Crawl → Fetch as Google
Optional: if you want to do a specific page only, type in the URL
Click Fetch
Click Submit to Index
Select either “URL” or “URL and its direct links”
Click OK and you’re done.
With the option above, as long as every page can be reached from some link on the initial page or a page that it links to, Google should recrawl the whole thing. If you want to explicitly tell it a list of pages to crawl on the domain, you can follow the directions to submit a sitemap.

Your second (and generally slower) option is, as seanbreeden pointed out, submitting here:

Found that there seo - How to request Google to re-crawl my website? - Stack Overflow

“Click Crawl → Fetch as Google”

This portion doesn’t exist in the webmastertools dashboard.

Did you try from the wordpress editor page? or fetch as google in webmaster dashboard I guess that can help you out...

WIth Regards,