Streaming live at 10am (PST)

File submission issues :/

Hi guys,

so I have a form on a client’s website, where they need users to upload a file and then submit. I have set in Project settings that the client receives an automatic email with all information collected by the form; including the uploaded file (as a .pdf link). When my client clicks on the link to view it, they receive this message:

“I get this when I try to hit that link: {“msg”:“You are not currently logged in”,“code”:401,“name”:“Unauthorized”,“path”:”/api/sites/curative2019/formUploads/3caba67c-db58-4305-8f46-769ec1a79c68.pdf",“err”:“Unauthorized: You are not currently logged in”}"

As a test, I tried sending the submitted forms to my email (which is the email I use for my Webflow account), yet I receive the same error. Inside Webflows settings, I can pull up the form and also see the PDF without a problem.

Does anybody understand this issue and know how to solve it? ://

MANY THANKS IN ADVANCE TO YOU GENIUS PERSON! :slight_smile:

Hi @Douglas_Fllrtn - just my first thought here. Have you tried unchecking login required?

… hate to admit it, but that was the problem. Thanks for this hehe

1 Like

I’m glad it’s all figured out - have a good one!

PS - @Douglas_Fllrtn, do you mind marking my answer as the solution :slight_smile:

1 Like

Thank you guy this salved part of my problem. now i need to embed the images in the email . dose anyone know how?

Where is the option to disable the login?

I have disabled login, as you can see here


Restrict uploaded file access

Turn this on to restrict access to files uploaded through your site’s forms to people who are logged in to your site, i.e., you, your client, and collaborators. Turn it off to allow public access to files, which you might need for certain publishing formats or integrations, like Zapier.

OFF

Login is not required


It Works!

Does this work for previous uploads? I have changed the setting and collaborators still cannot see the files