Streaming live at 10am (PST)

Error on import csv file


Trying to import A csv file and getting an error, thats fine, but where can I find instructions on how to import?

@shokoaviv if you click the link our CSV template. It will create a template for you that you can check against

Thanks for replying :slight_smile:
Downloaded the csv file and tried to import after inserting my products name, description etc. and still get an error. It must be A guide to import products but I can not find it (the instructions - how to).

Did you check the header in the file? I did quite alot and everything is not crystal clear

Hey @shokoaviv

I also had that error with my own CSV because I thought it would be like CMS import where you can match the fields, but it is not like that at the moment. So I dowloaded the template csv, copied my product info, then uploaded again. It worked, so I’m curious what might be different in your case.

If you don’t have paid hosting yet then you will be limited to 50 cms/product items total while on the staging plan.

Is there any more information you can give so we can better help you troubleshoot?

eComm is new to Webflow, and I’m new to eComm, everything is fine, first step is always difficult …
I can not import a list of products, I have probably errors, very curious to find out what my errors are. After a few attempts I found a link to learn whats wrong with my process, but it ends up with broken link :frowning:


For the lines referring to Variant Inventory, do you have a 0 or empty cell? Mine worked with empty cells. Any letters or decimal numbers because those might cause the error.

What values are in the Name error cells? I’m sure empty Name cells are not allowed because cms/product items can’t be created with out a name.

I happen to me only on Shop/Product collection. My other CMS Collection import works just fine.

This also happened to me.
I did this without success:

  1. Added the related fields to my previous “Products” collection in the CMS
  2. Renamed the Products CMS Collection
  3. Checked
  4. Exported my Products from the Products CMS Collection to CSV file.
  5. Tried to import my CSV file into the new Products area

I ended up with this exact error.

My assumption is that sufficient time has not been given to eCommerce as it compares to the CMS features of Webflow, but that it will as time rolls on.

Adding them all in manually. If I had more than 50, I’d use Zapier or similar.

1 Like

For Zapier.
Product doesn’t have info like price, dimension,quantity, etc. If those cannot be imported, zapier is not really helpful.
And what is that SKUs collection in zapier?

Hi - Thanks for being adventurous and using undocumented features in our Beta - it must be especially challenging for those new to Ecommerce so we’re working to make the documentation available soon.

To help unblock - the CSV template follows the Product Collection template. The fields Product Handle (which is the Collection Slug field you’re already used to), Product Name, and Variant Price are required. The remaining fields are optional and follow the same formatting as the Product fields allow.

We’ve even enabled Category mapping with the Product Categories field - if you have Categories defined we’ll map to them, if not we’ll create new ones for you.

We haven’t publicly enabled variants, but there are some fields (Option1 Name) in the template that give you a sneak peek of how we’ll enable importing them later.

@Lux - It looks like you’ve exported items from a regular Collection to a CSV. You’ll still need to format your products using the Product CSV template. You can download that CSV template in the Upload CSV modal - the link is at the top of the modal.

1 Like

This is key information, @anonymon hat surely helps, Monica. Thanks!

I’m having the following issues:

  1. If I add a variant set (i.e. add two columns: option4 name; option4 value), then I get the ‘header’ error
  2. If I try to upload without a category created yet, even if the cells in that column are blank, then I get an error (products won’t add)
  3. Seems like the product ‘alt description’ column (missing from template) also leads to an error (products won’t upload)

Any helps would be appreciated!!!