Error in site navigation

I believe that if you select the “dotted line” element and set it’s opacity to 0% it should work. Instead of setting the “Brif” section to brif, give the dotted line that name under Settings. :smiley:

Try giving your Header Section an ID of home. Since I can’t refresh to view changes in preview mode, I can’t tell if any of this is working haha.

I also recommend heading over to your Style Manager section and click on Clean Up because you have 13 unused classes. :wink:

Thank you . I think this is due to the fact that I was not properly fixed Navbar, tell me how to do it ? For example : http://mansardnye-okna-velux.ru/

Sorry, @MinewireNetwork, but I don’t think changing image opacity will help in this case. Plus if he will put ID “brif” to that image, scrolling will go even further.

What I would recommend is add a bit more padding to section “Brif” (70px instead 30px).

Of course! Click on a Navigation Link and then click on Settings on your Right Panel. Find “Link Settings” then click on “A Section on this Page” and select the corresponding section. :smiley:

Also @sabanna, I thought that he wanted it to go to that image when a certain nav link was clicked but he didn’t want it to be visible.

look 2nd picture: [quote=“Vyacheslav, post:1, topic:18363”]
This picture below shows how I want the page to look like after clicking the link(navbar), the boundary denoted by the dotted lines should be visible as shown.
[/quote]

should be visible :wink:

1 Like

I have done as you wrote , but the problem is that when I turn on the link that I have not seen this line

What exactly do you mean by turning on the link?

I do not speak in English , it is difficult to explain the problem , I’m sorry .
I want to push , and with reference to me appears the line, but when I click on the link I have it goes under the navigation bar

Можешь объяснить на русском, я переведу

Мне нужно зафиксировать навбар в верху страницы, я его зафиксировал, но теперь когда я нажимаю на ссылки в нем у меня переходит на нужную секцию но часть этой секции находится под навбаром. Я хочу сделать так чтобы этого небыло, и секция открывалась полностью

1 Like

Well, so my guess was correct. Vyacheslav wants that picture with dotted line was visible when navigation scrolling site to that section.

So here is something that you should understand. Scrolling navigation moving section to the screen view and stop section when top line of the section touching top line of the browser. In your situation you have 2 ways:

  • add more top padding to the section,
  • add some empty section right before “Brief” and make menu-link pointed to that empty section

P.S. Let me know if you need translation

2 Likes

Извините, что я не мог ! Я не уверен, что то, что сказал sabanna , но я предполагаю, что она помогла вам.

Удачного дня!

2 Likes

I still don’t know what can cause site moving down on load. Have any ideas?

looks like that issue is gone now

I have never experienced that issue before. I hope a staff member can help out, because this might be a bug. :confused:

Вопрос еще открыт, я думаю это из за того что я не правильно зафиксировал навбар, как правильно это сделать?

Russian language:


Здесь по ссылке разъяснения от одного из основателей “Вебфлоу” как корректно использовать настройки фиксированной навигации.

Основной смысл: для корректной работы скроллинг-навигации лучше всего сделать так, чтобы навбар находился внутри елемента с тегом <header> (ты можешь сделать из “div” в разделе “settings”)

Если у тебя есть “хедер” с фиксированной позицией, то браузер автоматически будет считать нижнюю границу хедера - самой верхней границей окна браузера (надеюсь понятно объяснила).

Поэтому, я бы советовала немного изменить структуру сайта (что не повлияет на вид сайта)

Все interactions теперь сделать не на фиксированный навбар, а на фиксированный хедер:

  • initial appearance: display=none
  • scroll interaction on “Header Section” (you have this already, calls “Show Navbar”, just change the element inside)

Не забудь сделать z-index выше, чем у обычного навбара.

С такими настройками твоя “brief” секция не будет перекрываться навигацией.

English:


There is Vlad explanation about correct using fixed headers and fixed navigation.

In short, if you want section stop it’s scrolling not behind fixed navbar, but right under the bottom line of it, will be better to put navbar inside the header tag (look settings tab)

So I would recommend to change site structure for a bit (it will not effect visual look) src=“//cdck-file-uploads-global.s3.dualstack.us-west-2.amazonaws.com/business5/uploads/webflow1/original/2X/d/da6dd2ed96fc150de3f72a2555611d5e786564d3.png” width=“628” height=“452”>

Then, all interactions should be applied on fixed-header (instead of fixed navbar):

  • initial appearance: display=none
  • scroll interaction on “Header Section” (you have this already, calls “Show Navbar”, just change the element inside)

Don’t forget to change fixed-header z-index to higher than “regular” navbar.
With such settings navigation will not cover part of “brief” section.

Regards,
Anna

1 Like

Огромное спасибо, я все сделал, работает, но теперь навбар появляется раньше положенного :unamused:

Измени значение “offset” в “Scroll Out of View”. Там можно использовать не только проценты, но и пиксели.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.